概　要

  『道路縦断計画支援システム』は 宅地造成や土地区画整理など複数の路線を同時に扱うことを想定した計算・作図システムです。機能と操作性は設計者の思考プロセスに基づいて開発されているため、基本設計から実施設計に至るまでのあらゆる場面に対応し、一般道路設計にも充分な成果を提供できるシステムです。

入力されたデータは、入力時および計算開始直前に自動チェックが行なわれ、エラーがあった場合はその個所とエラー内容を示すことで、利用者の無用な負担を軽減し、設計に集中できるよう配慮しています。

計算結果は、印刷をはじめ PDF、Excel、Word のファイルとして出力でき、作図はCALSに対応した DXF ファイルとして出力します。各出力とも簡単に画面でプレビューすることができ、時間と資源を無駄にすることなく、トライアルを繰り返すことが可能です。また、プレビュー画面からはページごとにメタファイル（WMF）としてコピーできますので、そのままExcel等に貼り付けることもできます。

Copyright(C) 2004 Dual Ltd.　 Dual


主な特徴

データ入力に関して

縦断計算に関して

縦断図作図に関して

● データ入力に関して

① 入力と同時に関連数値（勾配、縦断曲線半径、etc）を返しますので計画の判定を容易に行えます。更に、計画変化点データでは同時に縦断図を描き、図上で変化点の挿入、削除および移動ができますのでビジュアルに設計を行なうことが出来ます。

② 計画変化点データ入力では注目点を最大10箇所まで設けられ、その高さをリアルタイムに計算します。下限上限値入力すると図示されますのでコントロールポイントに対しシミュレーションが可能です。

③ ウィンドウズの標準的な操作により修正、追加、挿入、削除および移動ができます。また、Excel等他のアプリケーション間とのコピーアンドペーストができますので計画変更に容易に対応できます。

④ 計画変化点データは最大 7つまで扱え、計画データの複製が行えますので、複数案を比較設計するような場合も速やかに、また少ない労力で入力を行うことができます。

⑤ データ入力は測点（標高）を直接入力する方法と前データからの区間距離（高低差）で行う方法の２種類用意され、混合して使い分けることができます。また、計画変化点データでは前後のデータを基準にした勾配での入力および他路線の計画高の取込みを行うことができます。

⑥ 縦断勾配交点計算により、二つの計画高と勾配から交点位置および高さを求めることができます。求められた交点は新たな計画変化点データとして既に入力されたデータ間に挿入することができます。

⑦ バーチの重なりなどの簡単なエラーは該当個所が赤文字で示され、その他のエラーも入力終了時に内部チェックが行われ、不適当なデータ位置にエラー内容を示すメッセージが表示されますのでデータチェックの負担を軽減します。

⑧ 現況高の入力では標準測点自動生成機能（他データを参照して必要測点を自動的に生成）により、簡単に取り込めますので入力の手間を省くことができます。また、標高が比例的に変化する場合には両端を入力するだけで中間点を生成します。

● 縦断計算に関して

① マイナス測点、ブレーキの処理が行えます。

② 測点ピッチと計算ピッチは可変で、計算ピッチのラウンド上にない平面曲線の変曲点や交差点位置等の任意の測点を挿入することができ、点名(KA,BC,○○交差点 等）で表示を行なうこともできます。

③ 各点での拡巾、横断勾配のすり付けおよび路肩高の計算も同時にできます。

④ 任意点計画高計算によりマンホール位置、橋台、橋脚位置など必要点のみを計算・印刷することができます。

⑤ 高さによる位置の逆算および縦断曲線上の極値（高さ、位置）の計算ができます。

⑥ 入力データおよび計算値は印刷だけでなくPDF、WordおよびExcelにエクスポートできます。Excelエクスポートでは入力値を出力し合せて計算式を設定しますので、ユーザーが自由に加工することができます。

● 縦断図作図に関して

① 自路線だけでなく外部路線を含めた同時作図が可能で、最大１００路線の連続作図が可能です。

② 図面サイズ、帯タイプ、作図範囲および作図形態（バーチ部旗上げ種類等）などをユーザーが設定できます。設定は作図スタイルとして登録することで他路線で利用することができます。

また、外部路線を取り込んで作図することができますので、同一データを全く違うスタイルで作図することも可能です。

③ 計画高変更点、ブレーキ位置および指定位置の旗上げができます。

④ ＤＬ（Datum Line）は直接指定と自動決定の選択が可能で、自動の場合、入力された計画変化点データ、現況データおよび作図スタイルから決定しますのでユーザーの手を煩わせることはほとんどありません。

⑤ 延長の長い路線では複数図面に自動分割し、短い路線では指定により同一図面内に並べて作図することができます。

⑥ 入力測点範囲に拘わらず作図区間を指定することができます。前後にデータのない部分を付加したり、入力範囲の一部分だけを作図することができます。

⑦ 近接測点の帯び内文字、勾配図の近接縦断変化点では文字の重なりを可能な限り自動的に回避します。

⑧ 道路公団タイプの作図が行なえます。（別売オプションが必要です。）

⑨ 道路上の任意の測点から始点側、終点側を見た鳥瞰図が描けます。

⑩ 作図は基本的にＤＸＦファイル（CALSのﾚｲﾔ等に対応）に対して行いますが、プレビュー画面では印刷およびメタファイル（WMF）としてコピーが行なえますのでExcel等の他のアプリケーションに貼り付けることができます。


必要な実行環境

『道路縦断計画支援システム』を実行するには、以下の環境が必要です。

● ハードウェア

Windows98/ME/2000/XP日本語版が動作する環境。

12MB以上の空き領域を持つハードディスク。必要メモリ128ＭＢ（256MB以上推奨）。

Windows98/ME/2000/XP日本語版がサポートする A4サイズ印刷可能なプリンタ。

解像度800×600以上、カラーパレット256色以上（High Color16ビット以上推奨）表示可能なディスプレイ。

● ソフトウェア

Windows98/ME/2000/XP日本語版

＊Windows2000はService Pack 3 以上が必要です。

＊Windows2000/XPにインストールするには管理者権限でログオンする必要があります。

Internet Explorer 5.0以上

Excel 2000、Word 2000以降（推奨）

● プロテクションキー

プロダクツに同梱される『道路縦断計画支援システム』用のプロテクションキーが必要です。キーをUSBポートに接続し、デバイスドライバをインストールしなければなりません。詳細はプロテクションキーの設定を参照して下さい。

プロテクションキーが接続されていない場合には、デモ版として機能します。


ご利用にあたって

本ソフトは、利用者としてWindowsの初歩的な操作を理解し、道路縦断計画に関しては十分な知識を有するエンジニアを対象としています。

本ソフトでは使用の各ステップで様々なエラーメッセージ等を示しますが、これらはシステムが判断できる範囲の整合性の矛盾点を示すに過ぎず、本質的な原因を示すものではありません。したがって、これらのメッセージが示されなかったとしても、計算結果の正当性を保証するものではありません。また、一部には初期値が自動的にセットされるケースもありますので、入力データおよび計算結果はご利用される方が必ず確認するようにして下さい。


このヘルプは

このヘルプは『道路縦断計画支援システム』のヘルプの抜粋です。

目次のアイコンが [image] の項目のみ見ることができます。その他の項目は見ることができません。

更に詳細をお知りになりたい場合は、デモ版をダウンロードしてご覧下さい。


ヘルプの表記

   本システムは各データの相互関係を意識することで、入力の簡素化と省力化を計っています。各メニューおよび各画面で表示される入力項目は、上位で入力されたデータまたは作業状況により構成が変化します。

   このヘルプでの各種画面例は、なるべく多くの項目が表示されるよう構成されていますので、実際作業をするときにはこのヘルプ例通りに表示されるとは限りません。

以下のマークはそれぞれ次のような意味を持ちます。

ð 注意すべき事柄であることを示します。必ずお読み下さい。

ð 付加すべき一般的な情報であることを示します。

ð 知っておくと便利な情報である事を示します


作図での重なり回避

● 帯内文字位置

帯内の文字は2箇所まで前後に振り分けて重なりを回避します。それ以降は順次後ろに逃げて重なりを回避します。

● 帯内文字幅の縮小

文字列が帯内に納まらないときに文字幅を縮小して帯内に収めるように描画します。図面設定の帯詳細で［帯幅に納まらなくても文字を縮小しない］が選択されると帯内を飛び出してもそのまま描きます。

作図プレビューでは通常フォントを使用していますので縮小したときに文字が重なって表示されますが、CADでは文字幅が圧縮された形で表示されます。

● 勾配図

標準タイプでは、変化点の間隔により変化点位置の円を次のように変化させます。

変化点間が狭くて中に勾配文字を描けない場合は最大4スパンまで旗上げで重なりを回避します。但し、勾配欄が帯の最上段にない場合は旗上げは行なわず勾配の文字は描画しません。

● バーチ文字

バーチ文字は帯内２箇所までは前後に振り分けて重なりを回避します。但し、それ以降が重なる場合は体裁を考慮して文字を間引きます。図面設定の図詳細で［バーチ寸法の文字は体裁を考慮せずすべて描く］が選択された場合は体裁を無視して全ての文字を描きます。

● バーチ寸法位置

バーチ寸法は図面設定の図詳細で指定された位置に描きますが、下側に描いたときにDLライン上に出た勾配の旗上げの一段目位置より下になる場合、バーチ寸法の縦方向のサイズを縮めて描きます。サイズ変更で対応できない場合は、選択が下側であっても上側の向きに描きます。また、上側に描いたときに作図域上限を超える場合は逆に下側に向きを変えて描きます。

● 旗上げ

旗上げが重なる場合は、下図のように回避します。

● 縮尺三角形の位置

縦横の縮尺を示す三角形は通常DL文字の上に描かれますが、指標線と重なる場合は上に上げて回避します。

● 曲線図の文字

曲線図の文字は通常体裁を考え重なる部分は描かれません。図面設定の帯詳細で［曲線図で文字が重なった部分も描く］が選択されたときは重なっても描画します。

● 拡巾図、片勾配図の文字

測点が出力されない場合は、左右の拡巾量および勾配値は重ならないように変化位置の前後に振り分けて出力されますが、測点が出力されると測点を変化位置の手前、拡巾量および勾配値を後ろに出力します。測点が出力されない場合は、近接測点の文字は後ろに逃げますが、測点が出力された場合は重なりを回避できません。
   勾配値に付いては測点が出力された場合、文字列長が長いため左右の勾配値が重なるケースが多くなります。その場合小数点以下の出力桁数を少なくすることである程度回避できます。

● 橋梁・トンネル部の現況

橋梁やトンネルなど計画高と現況高の差が大きい場合は、DL高さから作図高さの範囲をはみ出す現況ラインを省略します。作図高さを超える場合はDLからの垂線のみが引かれます。但し、計画高が入力されていない場合はDLを図面途中で変更して全ての現況ラインを描きます。また、計画変化点データ入力時の図では省略されません。

重なり回避は完全ではありません。重なってしまった場合はCADソフトで移動して下さい。


使用上の制限

 | 項 目 | 制 限 | 摘 要
入力デ｜タ数の制限 | ブレーキデータ | 15 | 一路線につき
 | 計画 | 7 | 〃
 | 計画変化点データ | 200 | 一計画につき
 | 注目点 | 20 | 一路線につき
 | 平面線形データ | 200 | 〃
 | 拡巾データ | 200 | 〃
 | 横断勾配データ | 200 | 〃
 | 役杭データ | 500 | 〃
 | 現況データ | 1000 | 〃
 | 横断構造物データ | 50 | 〃
 | 任意点高さ計算点 | 200 | 〃
 | 高さ逆算計算点 | 200 | 〃
デ｜タの範囲 | 路線名 | 60文字 |
 | 杭名称 | 5文字 |
 | 測点ピッチ | 1m≦Ｐs≦9999m |
 | 計算ピッチ | 1m≦Ｐc≦9999m |
 | 半幅員（拡巾量） | 0m≦W≦99m |
 | 標準勾配（横断勾配） | -99%≦I≦99% |
 | 測点杭番号 | -99≦Ｓ≦9999 |
 | 標高 | -99m≦Ｈ≦2999m |
 | 区間距離 | 0m＜L≦9999m |
 | 点名（平面線形） | 10文字 |
 | （役杭） | 10文字 |
 | 旗上げ文字 | 20文字 |
 | メモ | 20文字 | 注目点、任意点高さ計算
作図に関する制限 | 作図データ数 | 100 | 一路線につき
 | スタイル数 | ディスク容量による |
 | 任意図面サイズ 最大幅 | 3200mm |
 | 〃 最大高さ | 1600mm |
 | 最大帯段数 | 20 | １スタイル当り
 | 図面上の測点数 | 1000 | 図面１枚における制限
 | ＤＬチェンジ数 | 10 | 〃 （DL自動決定時）
 | 変化点の重なり回避 | 4 | 連続短区間の勾配旗上げ回避の場合
 | 鳥瞰図計算点数 | 500 | １路線につき
 | 鳥瞰図視点高さ | -0.1≦Ｈ≦999 |
 | 鳥瞰図透視点までの距離 | 1≦L≦999 |
 | 鳥瞰図計算ピッチ | P≦1000 | 下限は計算点数による
 | 鳥瞰図誇張倍率 | 1≦M≦10 |


メニュー

メニューの項目をクリックして下さい。


ファイル

メニュー　［ファイル］

新規作成

   新規に『道路縦断計画支援システム』ファイルを開きます。新規ファイルにはNewData.jdd のファイル名が付けられます。
開く

   既に保存されたファイルを開きます。選択するとファイル選択ダイアログが表示されます。オプション設定でデフォルトのデータフォルダを設定できます。
上書き保存

作業中のファイルを、設定されているファイル名、保存場所を変更せずに保存します。
名前を付けて保存 | 　 作業中のファイルを、異なるファイル名、保存場所で保存します。
インポート

  DOS版データをインポートします。インポートは新規データを作成して行なわれます。但し、作図データはインポートされません。
エクスポート 　入力データおよび計算結果を各ファイルにエクスポートします。
Excel | ： | 1データ1シートとしてエクスポートします。単純な計算で求められる値はExcelの計算式がセットされます。
Word | ： | 各ページごとに図としてエクスポートします。図はグループ解除すると各要素に分解されますが、多くの場合ずれを生じます。
PDF | ： | しおりを自動作成してエクスポートします。
プリンタの設定 | 　 使用するプリンタの設定を行ないます。用紙サイズはA4固定となります。
ページ設定 | 　 印刷ページの様式を設定します。
印刷プレビュー

   印刷した時のイメージを画面に表示します。メニューから印刷プレビューを行なう場合は常にプレビューに先立って印刷項目の選択ダイアログが表示されます。
印刷

   入力データおよび計算結果を印刷します。印刷に先立ち印刷項目の選択ダイアログが表示されますので印刷項目を選択します。続いて印刷ダイアログが表示され、印刷項目印刷ページ及び印刷部数の指定を行うことができます。
図面設定 | 　 図面様式を設定します。
作図プレビュー

   作図した時のイメージを画面に表示します。作図データが入力されると有効になります。
DXF出力

   図面をDXFファイルに出力します。作図データが入力されると有効になります。
Recent File List

   最近開いたファイルの一覧表が、最大6つまで表示されます。これらのファイルをすばやく開くには、そのファイル名をクリックします。
終了

   『道路縦断計画支援システム』を終了します。まだ保存していない場合は保存するかどうかを確認するダイアログボックスを表示します。


ファイル

メニュー　［編集］

元に戻す | 直前の操作を元に戻したり、直前に入力したテキストを削除したりします。一度だけ戻すことができます。再度行なうと戻す前の状態になります。
切り取り | 選択した範囲のセルまたはテキストを削除し、クリップボードに保存します。
コピー | 選択した範囲のセルまたはテキストをクリップボードにコピーします。
貼り付け | クリップボードの内容をカーソル位置に挿入します。範囲が選択されている場合は、クリップボードに保存されている内容と置き換えられます。このコマンドはセルまたはテキストをコピーしたり切り取りした場合のみ使用できます。表形式では表への貼り付けを参照して下さい。
消去 | 表形式で有効で選択したセル内のデータを消去し、空白セルとします。
下方向へコピー | 表形式で有効で現在選択範囲のセルのデータを下の行にコピーします。このコマンドは、一行以内のセル範囲（列は複数でも可）が選択されている場合のみ使用できます。コピー後はコピー先をアクティブセルとします。この機能には [image] [image] [image] のショートカットキーが割り当てられています。下方向へのコピーは入力セルが空白のときに [image] キーの空打ちでも行なうことができます。また、マウスドラッグによるコピーでは下方向以外にもコピーが行なえます。
挿入 | 表形式で有効で空白のセルまたは行を挿入します。セルまたは行の挿入を参照して下さい。
削除 | テキスト入力では選択したテキストをクリップボードに保存せずに削除します。表形式ではセルまたは行の削除を参照して下さい。
すべて選択 | 表内のセル全体または現在対象となっているテキスト全体を選択します。
セル値に加算 | 表形式で選択範囲のセルの値に加算します。

マウス右ボタンクリックで表示されるショートカットメニューにもそれぞれ同様のメニューが表示されます。


ファイル

メニュー　［アクション］

［アクション］メニューは表形式入力時のみ有効で、入力対象データにより表示が異なります。.

先頭行へ移動 | 表の先頭行をアクティブセルとします。
最終行へ移動 | 表の入力済みの最終行をアクティブセルとします。
*1 計画追加 | 新しい計画を最終タブの後ろに追加します。追加に先立って計画名称入力ダイアログが表示されます。
*1 計画複製 | 現在の計画の複製を最終タブの後ろに作成します。
*1 計画削除 | 現在の計画を削除します。削除すると元に戻すことはできませんので処理に先立って確認のメッセージが表示されます。
*1 計画優先順位 | 計画の優先順位を変更します。
*1 計画名の変更 | 計画の名称を変更します。
*1 勾配入力 | 勾配から計画高を決定します。
*1 他路線参照 | 他の路線を参照して計画高を決定します。他路線参照を行なったセルの右上に [image] マークが付けられ後で参照することができます。
*2 計画から交点 計算へコピー | 交点計算で計画変化点データから測点、計画高および勾配をコピーします。
*3 交点計算結果を 計画に取込み | 交点計算の結果の測点および計画高を計画に取り込みます。
*4 平面線形データ 測点の挿入 | 平面線形データの測点を挿入します。
*5 拡巾データ測点 の挿入 | 拡巾データの測点を挿入します。
*6 標準測点の 一括挿入 | 計画変化点データ、平面線形データ、役杭データおよび計算ピッチ上の測点から生成した測点を一括して挿入します。
*7 空白標高の 比例計算 | 現況データで標高が空白のセルを前後の値から比例計算します。オプション設定で自動現況比例計算が選択されていれば空白部は必ずしも計算する必要はなく、縦断計算または作図に先だって自動的に計算されます。
*8 連続範囲高さの 挿入 | 高さ位置逆算で有効になります。連続範囲高さの挿入は等高線のように同一ピッチの高さを連続して入力するときに使用します。ダイアログボックスが表示され開始、終了高さおよび計算ピッチを指定します。
*8 バーチ極値の 挿入 | 縦断曲線上の最大最小（最高最低）標高を計算します。分水嶺、集水位置を知ることができます。極値が無い場合はその旨をメッセージします。
*9 測点順に 並び替え | 表内のデータを測点順にソートして並び替えます。
*8 高さ順に 並び替え | 表内のデータを高さ順にソートして並び替えます。
*10 初期化 | 入力値をシステムが定める初期状態にします。

*1 計画変化点データ入力で有効になります。

*2 計画変化点データで交点計算のセル内が選択されたときに有効になります。

*3 計画変化点データで交点計算のセル内が選択され計算結果が表示されているときに有効になります。

*4 拡巾データおよび横断勾配データ入力で有効になります。

*5 横断勾配データ入力で有効になります。

*6 現況データ入力および任意点高さ計算で有効になります。

*7 現況データ入力で有効になります。

*8 高さ位置逆算で有効になります。

*9 役杭データ、現況データ、横断構造物データ、任意点高さ計算および高さ位置逆算で有効になります。

*10 鳥瞰図作図データで有効になります。


ツールバー

標準ツールバー

データツールバー

*既に開かれているデータのボタンは暗水色の文字で表示され、現在アクティブなデータのボタンはボタンが押された状態になります。

アクションツールバー

*状況にあわせ使用可能なボタンのみ表示されますので実際の表示とは異なります。

ボタンをクリックして下さい。


一般共通事項

操作に関してはWindows の標準的な手法に倣っています。以下には『道路縦断計画支援システム』で採用しているいくつかの操作の補足を示します。

● テキスト、数値入力時の処理

テキストおよび数値入力では、フォーカスを持った時に選択状態になります。ただし、マウスを使用した数値入力では、右揃えで表示された文字列の右端の部分をクリックすると全体が選択された状態になり、左端をクリックすると非選択状態となります。文字列中間をクリックすると、左端文字とクリックした位置までが選択状態になります。

● 入力項目に関する解説

入力項目がフォーカスを持つと、その入力項目に関する簡単な解説がステータスバーに表示されます。

● 測点入力

測点の入力は、杭番号とオフセット値（プラス杭）のセットで入力します。（考え方と処理・測点の表現参照）。杭番号またはオフセット値の片方が入力されていて片方が空白の場合は、空白側は０(ｾﾞﾛ)として認識します。測点入力では、入力される測点の順序は特にことわりが無い限り、始点から終点へ向けて順次入力されている必要があります。

● 区間距離入力

測点を入力すると自動的に計算されますが、直前測点からの区間距離を入力するとブレーキを考慮した測点が逆に代入されます。表形式で測点のプラス杭入力を [image] キーで終了したときは区間距離セルは飛ばされ次の入力可能セルをアクティブセルとします。但し、 [image] [image] [image] [image] キーでは位置付けることができます。

● 高低差入力

標高は通常標高値で入力しますが、先頭に／(ｽﾗｯｼｭ)を付けて数値を入力すると直前標高からの標高差として入力することができます。

● エラーに対する処理

範囲外の値が入力された場合など簡易なエラーに対しては、原因となった入力位置に、以下のようなエラーチップボックスが表示されます。エラーチップボックスはいずれかのキーに触れるか、原因となった入力位置あるいはエラーチップボックスをマウスでクリックすると閉じられます。

上記以外の重大なエラーの場合は、一般的なエラーメッセージが表示されます。この場合はエラーを確認後、メッセージを閉じるボタンをクリックして下さい。

● ボタン

入力データを確定して入力ウィンドウを閉じます。確定前にデータチェックが行われ、エラーがあった場合上記エラーチップボックスが示されます。データが確定されると関連する入力ウィンドウの項目が変更されます。 がショートカットキーとして割り当てられています。

● ボタン

入力データを破棄して入力ウィンドウを閉じます。 キーがショートカットキーとして割り当てられています。

● ボタン

データが変更されるとアクティブになります。クリックすると既に変更されたデータを確定して未変更の状態とします。確定前にデータチェックが行われ、エラーがあった場合エラーチップボックスが示されます。データが確定されると関連する入力ウィンドウの項目が変更されます。 がショートカットキーとして割り当てられています。

データが変更されると整合性が失われるため、既に示された結果を破棄します。ツールバーによる印刷プレビューでは印刷項目の再設定が必要となります。また、測点ピッチやブレーキが変更されると他の全てのデータのチェックが必要なため全ての入力ウィンドウが閉じられます。

● ボタン

入力ウィンドウの [image] は、 [image] ボタンと同じ扱いとなります。

≪強制終了≫

入力データの保存に際しては常にデータチェックが行われ、正しいデータが入力されるまで保存することはできません。こうした処理は、システムが提供する結果への安全性を確保する上で不可欠なものではありますが、同時に一般作業の合間にシステムを扱うなど、時間の有効利用という観点からは融通性を損なう原因ともなります。

こうした問題に対処するため [image] キーと [image] キーを同時に押しながらOKボタンをクリックすると強制終了を行うことができます。強制終了ではデータのチェックを行わずそのまま保存することができます。ただし、強制終了を行った場合は、必ずあとでOKボタンだけで終了できるか確認して下さい。


表形式のインターフェース

表形式の共通事項

以下には『道路縦断計画支援システム』の表形式入力における共通事項を示します。

● セルの背景色

入力可能なセルは背景が白色、計算項目など入力の必要のないセルは背景をグレーで示します。また、列内で一部分が入力禁止となるセルでは背景をグレーとして [image] マークが付けられます。

● セル移動

移動キー [image] [image] [image] [image] またはマウスで行なうことができます。移動キーを使用した移動では、入力禁止セルを飛ばして入力可能セル間を移動し、マウスによる移動では自由に移動することができます。

また、セル入力後に Enter キーを押すとセル位置を右方向へ移します。最右端のセルの場合は、一行下の最左端のセルへ移動します。ただし、移動先が入力禁止セルまたは区間距離セルの場合は次の入力可能セルまで飛ばされます。

● セルの入力モード

ファンクションキー [image] を押すと入力モードとなり、既に入力された文字列の選択状態になります。マウスの左ボタンをダブルクリックするか、 ｽﾍﾟｰｽ キーまたは Enter キーでは同様に入力モードとなりますが、選択状態にならずキャレットが文字列の末尾に位置づけられます。その他の文字キーを押すと新規入力モードとなります。

入力モードになったセルの操作は一般共通事項に示すテキスト、数値入力時の処理と同じです。

● 空白セルへの直上行の値のコピー

オプションの設定により空白セルで Enter キーを空打ちすると直上の行の値がコピーされます。既に入力済みのセルへ直上行の値をコピーするには、［編集］メニューの［下方向へコピー］で行ないます。

● セル値に加算

セルを選択して、［編集］メニューの［セル値に加算］をクリックすると以下のようなダイアログが表示されますので加算したい値を入力して［OK］ボタンをクリックします。選択範囲に入力可能セルにのみ行なわれます。

● 選択セルでの選択方法

選択項目を持つセルがアクティブになるとセルの右側に [image] ボタン表示されます。 ボタンをクリックすると選択項目がドロップ表示されますので [image] [image] キーかマウスで選択します。しかしながら、こうした操作は連続した作業を行なうときに効率的とはいえません。本システムでは選択項目にキーを割当て有り ［0］～[9]、［A]～[F]キーを押すことで簡単に入力を行なうことができます。キーの割当はそれぞれの入力で異なりますが、多くの場合は入力時にステータスバーに解説が示されます。

● マウスドラッグによるコピー

以下の手順でマウスドラッグによるコピーを行なうことができます。複数のセルを同時にコピーすることができます。

① [image] キーを押しながらセルの枠部分にマウスを移動します。

② [image] キーを押したままマウスの左ボタンクリックしてコピー先に移動します。

③ マウスボタンを離すとコピーが完了します。

    手順①　　　　　　　　　手順②　　　　　　　　　手順③

● 表への貼り付け

表形式入力時の貼り付けでは、コピー領域より貼り付け領域が大きい場合、貼り付け範囲が一杯になるまで繰り返して貼りつけられます。この時、貼り付け範囲はコピー範囲の整数倍の範囲でなければなりません。

貼り付け先の左上は必ず入力可能セルでなければなりません。また、貼り付け位置が入力禁止セルに当たるデータは無視されます。

● セルまたは行の挿入

現在選択されているセル位置に空白セルを挿入し、現在データを下方向へシフトします。行全体が選択されている場合は行が挿入されます。一部のセル範囲が選択されている場合は、該当列のみに空白セルが挿入されます。選択範囲が複数行の場合は、選択された行数分のセルが挿入されます。挿入の結果が表の最終行を超える場合は、超えた部分のデータは失われますので注意して下さい。

● セルまたは行の削除

表形式入力では現在選択されたセル範囲のデータを削除し、選択範囲以降のデータを上方向にシフトします。行全体が選択されている場合は行が削除されます。一部のセル範囲が選択されている場合は、該当列のみが対象となります。削除範囲にシフトする下方向のデータ範囲が表の最終行を超える場合は空白で埋められます。

● 行の移動

以下の手順で行移動を行なうことができます。複数の行を同時に移動することができます。

① 表の行タイトル部分をクリックして行全体を選択します。

② 選択された行の反転部分にマウスを移動してマウスの左ボタンをクリックします。

③ マウスボタンを押したまま移動したい行までドラッグします。

④ マウスボタンを離すと移動が完了します。ただし、行番号は新たに付け替えられます。

アニメーションを再生


計画変化点データ

   計画縦断線形の変化点を入力します。計画の無い縦断図では入力の必要はありません。縦断図と表の範囲は間にある境界部分をドラッグすることで調整することができます。

測点 | 縦断勾配の変化点の測点を入力します。 同一測点は２点まで許可されます。
区間距離 | 測点を入力すると自動的に計算されますが、区間距離を入力することもできます。
追加距離 | 測点の入力によりブレーキを考慮した追加距離が自動的に表示されます。
計画高 | 縦断勾配の変化点の計画高さを入力します。高低差入力、勾配入力、他路線参照によって入力することもできます。数値の先頭に／(ｽﾗｯｼｭ)を付けると直前標高からの高低差で入力することができます。
バーチ長 | 縦断曲線長を入力します。ただし、先頭行は入力禁止となり、最終データでは入力値があっても無視されます。
勾配 | 測点，計画高から勾配が計算され勾配値(%)と上り( [image] )、下り( [image] )、レベル（ [image] ）、∞（ [image] ）の記号が表示されます。
バーチ間 | 二つの変化点の縦断曲線に挟まれる直線部の距離を表示します。バーチ間がマイナスになると縦断曲線が重なっていることを示します。
半径 | 縦断曲線半径（上位３桁目を四捨五入）とサグ( [image] )、クレスト( [image] )の記号が表示されます。測点またはバーチ長に矛盾があると赤で ?ﾊﾞｰﾁ重 と表示されます。

計画の優先順位

入力時の縦断図

注目点

交点計算


他路線参照

計画高の入力位置になると［アクション］メニューの［他路線参照］またはツールバーの [image] ボタンが有効になり、クリックすると下のようなダイアログボックスが開かれます。参照する路線のファイル名と測点を入力します。路線のファイル名は［参照］ボタンをクリックすることで参照して取込むことができます。

他路線参照を行なったセルの右上には [image] マークがつけられ［表示］メニューの参照情報表示により参照情報を表示させることができます。また、再度他路線参照を行なう場合は上記ダイアログには前回参照した値がセットされます。

● 参照後に計画高を直接入力すると参照情報は破棄されます。
● 参照先路線が変更になっても自動更新はされません。再度他路線参照を行なって下さい。


入力時の縦断図

入力に連動して縦断図を描画します。縦断図は現在編集中の計画または確定した現況データの範囲の全体を描きます。縦横の縮尺は内部で自動的に決定されます。

図をクリックすると図表示モード（背景が白）となり、マウス位置の測点と高さをステータスバーに表示します。図上で変化点を挿入、削除および移動することもできます。

① | 現在編集中の計画ライン。
② | 現況ラインを茶色で描きます。既に入力されている場合に描かれます。垂線は全ての点に引かれます。
③ | 現在編集中の変化点の位置を■で示します。
④⑤ | 注目点で入力された位置と上限下限の範囲を示します。計画高が範囲を超えると紫色で表示されます。
⑥ | 注目点で入力された位置を示します。上限下限の範囲が入力されていない場合は作図範囲全体に線が引かれます。
⑦ | バーチ長（縦断曲線長）の範囲を示します。サグでは上側に、クレストでは下側に描きます。
⑧ | マウスカーソルを変化点位置に置くと、その変化点の測点と高さがポップアップ表示されます。また、変化点位置をクリックすると、表の該当個所がアクティブセルになります。
⑨ | クロス（十字）カーソルでマウス位置に引かれます。クロスカーソルは SHIFT キーを押しながらダブルクリックすることで表示・非表示を切り替えることができます。 上図ではクロスカーソルが引かれていますが、実際はマウスが変化点上にある時は表示されません。
⑩ | 横断構造物を赤色で描きます。
⑪ | 図の表示用ツールバー。全体表示、拡大縮小が行なえます。各ボタンの機能に付いては上図のボタンをクリックすると簡単な解説がポップアップされます。変化点の操作については後述を参照して下さい。

● 図表示モード

図表示モードでは図の背景が白色になります。図表示モードではマウス位置にクロスカーソル（十字線）が表示され測点と高さを以下のようにステータスバーに表示します。

測点 | マウス位置の測点を表示します。
H | マウス位置の高さを示します。
PH | マウス位置の測点における計画高を示します。
GH | マウス位置の測点における現況高を示します。
Δｈ | マウス位置の測点における現況高と計画高の差を表示します。切土を＋(ﾌﾟﾗｽ)、盛土を－(ﾏｲﾅｽ)で示します。

画面の解像度や表示の拡大率の関係などから、マウス位置の測点および高さと、作図される測点と高さとは一致しない場合があります。

● マウス操作での表示変更

拡大縮小 | ツールバー以外にマウスによる拡大縮小を行なうことができます。 キーを押すとマウスカーソルが変わります。左ボタンをクリックすると拡大、右ボタンをクリックすると縮小されます。 キーを押しながらマウスホイールを前後に回転することでも拡大縮小が行なえます。
表示移動 | 拡大表示されているときに、スクロールバーで移動するか、マウスの左ボタンを押したままドラッグすることで表示範囲を移動することができます。

● 図上でのデータ操作

変化点の移動 | ツールバーの [image] ボタンをクリックすると変化点移動モードになり各変化点に緑色の■（ﾊﾝﾄﾞﾙ）が表示されます。移動したいハンドルをドラッグ（マウスの左ボタンを押したまま移動して目的個所でマウスボタンを離す）します。 キーを押すと垂直または水平方向にだけ移動します。
変化点の挿入 | ツールバーの [image] ボタンをクリックすると変化点挿入モードとなります。挿入したい位置でマウスの左ボタンをクリックすると新しい変化点が挿入されます。
変化点の削除 | ツールバーの [image] ボタンをクリックすると変化点削除モードになり各変化点に赤色の■(ﾊﾝﾄﾞﾙ)が表示されます。削除したいハンドルをマウスの左ボタンでクリックします。

各操作の実行時はツールバーのボタンは押された状態になります。再びボタンをクリックするかマウスの右クリックまたは [image] キーを押すと中止することができます。また、その他にも表示を変更した場合など自動的に解除される場合があります。

計画変化点データ


作図データ

   作図対象路線、作図範囲、ＤＬ高さ、図面上の作図位置および作図有無を設定します。

路線種別 | 作図する路線の種別を［自路線］、［外部］および［DL変化］から選択します。［DL変化］は図面の途中でDLを変更する場合に選択します。 ［DL変化］を選択すると、上の行で［DL変化］以外の路線種別の路線が対象になります。
路線ファイル名 | 路線種別が［外部］のときに、作図する路線が保存されているファイル名を入力します。オプション設定で指定したデータフォルダにない場合はフルパス名で入力します。セルの右側の [image] ボタンをクリックするとファイル参照して入力できます。
開始測点 終了測点 | 作図を開始、終了する測点を入力します。測点は標準測点上の点でなければなりません。 路線種別が［DL変化］の場合には開始測点は入力禁止となり、直上の行の終了測点と同一と見なされます。 路線種別または路線ファイル名が変更されると、作図始終点の測点には計画変化点データ（計画が無いときは現況データ）と平面線形データの始終点のそれぞれ最小最大の測点が自動的に代入され ます。
追加距離 | 測点の入力によりそれぞれの路線のブレーキを考慮した追加距離が自動的に表示されます。
DL高 | 作図時のＤＬ（Datum Line）の高さを入力します。ＤＬが空白ならば内部で自動計算さ れ、必要に応じて１図面中10段まで途中で切り替えます。ほとんどの場合入力の必要はありません。 ＤＬが入力されると作図が複数枚にわたる場合も全て同じ高さで描きます。複数枚にわたる路線を異なるＤＬ高で作図するときは、１ 枚毎に作図区間を指定し、それぞれにＤＬ高を入力することで思い通りの作図を行うことができます。 指定の範囲と高さにより図面の途中でDLを変更するため路線種別で［DL変化］を選択したときは必ず入力しなければなりません。
図面位置 | 図面位置は以下の中から選択します。路線種別が［DL変化］の場合は入力できません。 [1] 新規 ･･･ 路線の長さに拘らず図面の先頭から描きます。 [2] 並描 ･･･ 先に作図した路線が短く、図面上に並列で描く余裕があれば前路線の後方に作図します。余裕が無ければ確認ダイアログが表示され、OKの場合は次の図面の先頭から描かれます。
作図有無 | 今回の作図対象とする場合はチェックします。路線種別が［DL変化］の場合は入力できず、上の行ので［DL変化］以外の路線種別の路線の選択によります。

  作図データでは列幅を変更することができます。マウスカーソルを列タイトルの中間に持っていくとマウスカーソルが変化しますので、左ボタンを押したまま左右にドラックして下さい。


任意点計画高計算

   橋台･橋脚、マンホール位置など任意なポイントの高さだけを計算したいとき、または全体の中のある範囲だけの計算値が必要なときに選択します。測点が入力されるとリアルタイムに計算を行います。計算は第１計画に対して行なわれます。他の計画データで計算したいときは計画の優先順位を変更して下さい。

測点 | 計算したい任意点の測点を入力します。次候補取込みおよび標準測点の一括挿入で入力することができます。また、測点順に並べ替えることができます。
区間距離 | 測点を入力すると自動的に計算されますが、区間距離を入力することもできます。距離がマイナスの場合は紫色で表示されますがエラーにはなりません。
追加距離 | 測点の入力によりブレーキを考慮した追加距離が自動的に表示されます。
シフト量 | センターからのシフト量を入力します。セルが空白のときはセンターライン上の計画高が計算されます。 シフト量がアクティブセルになるとステータスバーに有効な幅員が表示されます。シフト量が幅員を超えるとエラーとなり赤色で表示されます。路肩位置の場合は［左路肩］または［右路肩］を選択します。 シフト量が入力されてセンター以外の計画高が入力されると、計画高等は青緑色で表示され、センターライン上の時は暗緑色で表示されます。
計画高 | 計算された計画高を表示します。
比例高 横勾配 | センターライン上の計画高が計算されたときは計算測点の比例高さ（縦断曲線を考慮しない高さ）を表示します。 シフト量が入力された場合は、計算測点位置の横断勾配が表示されます。
バーチ高 横差高 | センターライン上の計画高が計算されたときは計算測点の縦断曲線による縦距を表示します。 シフト量が入力された場合は、計算点の計画高とセンターライン上の計画高との横断勾配による差が表示されます。
メモ | 任意点に関するメモを20文字以内で入力します。

  同一点（測点とシフト量が同じ）は入力することはできません。


印刷プレビュー

   印刷イメージを画面で見ることができます。

次ページ
前ページ

  ［次ページ］［前ページ］ボタンをクリックすると１ページ分移動します。現在ページと全ページ数は下のステータスバーに表示されます。 キーを押しながらのマウスホイールでもページ送りが行なわれます。キーボードでは Page UP キーは前ページに、 Page Down キーは次ページに対応します。また、 [image] [image] Page UP で先頭ページに、 [image] [image] Page Down で最終ページに移動します。
拡大
縮小

   ［拡大］［縮小］ボタンをクリックすると表示を拡大または縮小することができます。拡大縮小は、全体表示⇔７５％⇔１００％⇔１５０％⇔２００％⇔３００％⇔4００％の範囲で行われます。 キーを押しながらのマウスボタンの左クリックで拡大、右クリックで縮小、マウスホイールの前後でもそれぞれ拡大縮小できます。
表示移動

   拡大時のプレビュー位置はスクロールバーを使用する方法と、マウスのクリックとドラッグにより行うことができます。プレビュー画面上のマウスカーソルは [image] で表示されます。移動したい位置の中心でマウスの左ボタンをクリックするとマウスカーソルが [image] に変わります。マウスの左ボタンを押したままドラッグすると自由にスクロールします。　 ≪ちょっと裏技≫

移動前のマウスカーソル [image] はプレビュー上で [image] キーを押しながらダブルクリックすると [image] に変わります。プロジェクターを使用して説明するときなどのポインターとして使用できます。
表示タイプ

   ボタン右側の [image] をクリックするとドロップダウンメニューが表示され、［1ページ表示］、［2ページ表示］および［サムネイル］の表示を選択することができます。表示されたページをクリックするとそのページが表示されます。

非表示･表示 | 　 ボタンのクリックで左側の目次ツリーを表示または非表示にすることができます。
ページ印刷 | 　 現在の表示ページを印刷します。
閉じる | 　 プレビューを閉じてメインウィンドウに戻ります。

このページの
コピー

   プレビュー上でマウス右ボタンをクリックしたときのショートカットメニューで選択することができます。現在表示されているページをメタファイル（．WMF)としてクリップボードへコピーします。


エクスポート　［PDF］

  ［ファイル］メニューの［エクスポート］-［PDFﾌｧｲﾙへエクスポート］をクリックするとファイル名入力ダイアログが表示されます。続いてエクスポート項目の選択ダイアログが表示され、選択した項目をPDFにエクスポートすることができます。
   PDFには自動的に｢しおり｣が作成されます。PDF（Portable Document Format）ファイルとすることで電子メールなどで送信したり電子納品に対応することができます。

本システムは独自にPDF出力する機能を有していますので Writer等のソフトは必要ありません。ただし、PDFファイルを表示するにはAdobe Systems 社のフリーソフト Acrobat Reader 等が必要です。お持ちでない方はAdobe® Reader のホームページよりダウンロードすることができます。


作図プレビュー

   作図イメージを画面で見ることができます。

次ページ
前ページ

  ［次ページ］［前ページ］ボタンをクリックすると１ページ分移動します。現在ページと全ページ数は下のステータスバーに表示されます。キーボードでは Page UP キーは前ページに、 Page Down キーは次ページに対応します。また、 [image] [image] Page UP で先頭ページに、 [image] [image] Page Down で最終ページに移動します。
全体

   ページ全体を表示します。
拡大
縮小

   ［拡大］［縮小］ボタンをクリックすると表示を拡大または縮小することができます。拡大縮小は、１％～６００％の範囲で行われます。 キーを押しながらのマウスボタンの左クリックで拡大、右クリックで縮小、マウスホイールの前後でもそれぞれ拡大縮小できます。
範囲指定で拡大

   拡大範囲の左上と右下のポイントを指定してその範囲全体が表示されるように画面表示を拡大します。
表示移動

   拡大時のプレビュー位置はスクロールバーを使用する方法と、マウスのクリックとドラッグにより行うことができます。プレビュー画面上のマウスカーソルは [image] で表示されます。移動したい位置の中心でマウスの左ボタンをクリックするとマウスカーソルが [image] に変わります。マウスの左ボタンを押したままドラッグすると自由にスクロールします。　 ≪ちょっと裏技≫

移動前のマウスカーソル [image] はプレビュー上で [image] キーを押しながらダブルクリックすると [image] に変わります。プロジェクターを使用して説明するときなどのポインターとして使用できます。
表示タイプ

   ボタン右側の [image] をクリックするとドロップダウンメニューが表示され、［1ページ表示］、［2ページ表示］および［サムネイル］の表示を選択することができます。表示されたページをクリックするとそのページ表示されます。

ページ印刷 | 　 現在の表示ページを印刷します。サムネイル表示では全ページ印刷となります。印刷に先立ち印刷ダイアログが表示されます。A3サイズを印刷サイズの既定値とします。また、印刷のページ設定でカラーを使用しないが選択されていると白黒モードで出力されます。
DXF | 　 現在の表示ページをDXFファイルに出力します。全ページを出力するには［ファイル］メニューから［DXF出力］を選択して下さい。
閉じる | 　 プレビューを閉じてメインウィンドウに戻ります。

このページの
コピー

   プレビュー上でマウス右ボタンをクリックしたときのショートカットメニューで選択することができます。現在表示されているページをメタファイル（．WMF)としてクリップボードへコピーします。

● 作図プレビューでは通常のフォントを使用して文字を描いていますので、DXFへ出力される図とは若干異なります。

● プレビューからメタファイルとして貼り付けた場合に、ソフトによっては図が乱れる場合があります。その場合は一度他のソフトに貼り付けた上で、再度コピーして貼り付けると上手くいく場合があります。試行ではＭｉｃｒｏｓｏｆｔ WｏｒｄやPoweｒPointは比較的好ましいケースが多くありました。


図面設定　［配置］

   図面上の配置を設定します。アクティブセルに対応した文字が図中で点滅します。図中の文字をクリックすると対応するセルをアクティブにします。また、入力位置により図の表示が変化します。

W1 | 図面内枠左側とDLライン左端との離れを 0～200mmの範囲で入力します。
W2 | 図面内枠左側と帯タイトル枠左端との離れを 0～200mmの範囲で入力します。
W3 | 高さ指標線と最初の測点との離れを 5～100mmの範囲で入力します。
W4 | 複数路線を同一図面上に描く場合の路線間のスペースを 10～300mmの範囲で入力します。
W5 | 図面内枠右側と帯右端との離れを 0～300mmの範囲で入力します。
W6 | 帯タイトル枠の長さを 10～100mmの範囲で入力します。
W7 | 帯タイトル枠と帯との離れを 0～50mmの範囲で入力します。
P1 | 最終測点と帯右端との離れを 0～50mmの範囲で入力します。但し、値によらずW5の範囲を超えません。空白なら常にW5まで描画します。この設定により以下のように帯の長さが異なります。 並列に複数の路線が作図されるときにP1が入力されると、帯の線は最も左側の路線にのみ引かれ、以降の路線には帯線を引きません。単独路線を作図するときにのみ使用してください。
H1 | 図面内枠左側と帯下端との離れを 0～300mmの範囲で入力します。
H2 | 高さ指標線の作図高さを 50～600mmの範囲で入力します。DL位置高さより上にこの高さが確保できないときはエラーとなります。
H3 | ＤＬ上の作図高さを 50～600mmの範囲で入力します。DL位置高さより上にこの高さが確保できないときはエラーとなります。
H4 | 旗上げの開始高さをＤＬからの離れで 50～800mmの範囲で入力します。図形により調整されることがあります。
H5 | 旗上げの垂線部の長さを 5～150mmの範囲で入力します。図形により調整されることがあります。
H6 | 帯上端とＤＬラインとの間隔を 0～50mmの範囲で入力します。
H7 | 内枠上端と路線名文字下端の間隔を 5～100mmの範囲で入力します。水平方向は路線作図範囲の中心となります。
L1 | 旗上げの斜め線の長さを 20～150mmの範囲で入力します。角度は常に 30ﾟで描かれます。

図面設定終了時には図面サイズ、帯項目の帯高およびここでの各寸法の整合性がチェックされます。入力された寸法が図面内に収まらない場合はエラーメッセージに推定値を示しますが、システムが指定した値が原因とは限りませんので全体を見て修正して下さい。
エラーの原因が不明な場合は強制終了を行い一旦作図してみて下さい。ただし、致命的なエラーが含まれていた場合にはシステムダウンすることがあるかも知れませんので事前にデータの保存をしてから行なって下さい。


図面設定　［帯項目］

   各帯の属性、タイトルおよび寸法を設定します。

属性

  帯の属性を入力します。帯の属性は以下の種類から選択します。

測点 | 測点または点名が描かれます。
単距離 | 測点間の単距離が描かれます。
追加距離 | 追加距離が描かれます。
現況高 | 現況標高が描かれます。
計画高 | 計画高（第１計画）が描かれます。
切土高 | 切土高（現況標高－計画高（第１計画）≧０の値）が描かれます。
盛土高 | 盛土高（計画高（第１計画）－現況標高＞０の値）が描かれます。
勾配図 | 縦断線形変化点位置、勾配および区間距離が描かれます。作図勾配図が帯最上段にない場合は、重複回避の旗上げは行われません。 作図スタイルが道路公団のときはタイトルは入力できません。
曲線図 | 平面線形曲線図が描かれます。
拡巾図 | 道路拡巾図が描かれます。（標準タイプのみ選択可能です。）
片勾配図 | 標準タイプでは片勾配図、道路公団タイプでは片勾配摺付図が描かれます。
左路肩 | 左側路肩の計画高が描かれます。
右路肩 | 右側路肩の計画高が描かれます。
第２計画高 ～第７計画高 | 第２計画～第７計画の計画高が描かれます。
空欄 | 帯内にはなにも描かれません。
作図時
タイトル

  作図時の帯タイトルを入力します。タイトルは２段まで入力することができ、一段につき７文字まで入力できます。２段とするには [image] [image] [image] で改行します。作図では均等割付けされます。
帯高

   帯の高さを 10～100mmの範囲で入力します。

帯間

   帯間の離れを 0～5mmの範囲で入力します。ただし、最下段の入力値は無視されます。


図面設定　［線種］

   各部の線の種類を設定します。

太さ | 線の太さを 0.00mm ～ 3.00mmの範囲で入力して下さい。0mmの場合は最細線で描画されます。太さはプレビューや印刷では反映されますがDXFファイルには反映されません。
線種 | 線の種類を［実線］、［破線］、［一点鎖線］、［二点鎖線］および［点線］の中から選択します。 ただし、路線名では文字のため下線の有無のみ指定できます。
色 | 線の色を選択します。セル右の [image] ボタンをクリックすると色選択ダイアログが表示されます。本システムで使用する色はExcelの使用色にあわせてありますが、DXFファイルでは最も近い色番号に変更して出力されます。
描画 | 描画を行なう場合にチェックします。複数の計画案を重ねて描きたいときには各計画をチェックします。複数案を検討したが、第1計画のみ描きたいときには、他の計画のチェックを外します。 その他の項目で描画しないとすると、その項目に関する文字も描画されません。

描画位置は下図を参照して下さい。