目　　次

はじめに

必要な実行環境

アドイン登録と削除

『 Dual Plus For Excel Pro 』でできること

数式および値の貼り付け

テキストの縦位置の指定

定型句

ブックマーク

セル情報の表示

書式リスト

式の参照元一覧

シート管理

セル文字列による名前定義

名前リスト

etc.

縦方向に結合

非ロックセルの選択

外部参照セルの選択

ヘルプ表示とバージョン情報

その他

エキスパートモード

Excel2007での注意

使用条件について

著作権


必要な実行環境

『 Dual Plus For Excel Pro 』を実行するには、以下の環境が必要です。

● ハードウェア

Windows XP日本語版が動作する環境。

2MB以上の空き領域を持つハードディスク。必要メモリ256MB。

解像度800×600以上、カラーパレット High Color16ビット以 上 表示可能なディスプレイ。

● ソフトウェア

Windows XP Home Edition日本語版、Windows XP Professional Edition日本語版

＊Windows XP はService Pack 2 以上が必要です。

Microsoft Excel 2000、2002、 2003、 2007

実行するには エクセルのツールメニューの［マクロ］-［セキュリティ］の［セキュリティレベル］は［中］または［低］とし、［信頼のおける発行元］タブで［組み込み済みのアドインとテンプレートをすべて信頼する］をチェック 、［Visual Basicプロジェクトへのアクセスを信頼する］もチェックしてください。

● 実行許可

『 Dual Plus For Excel Pro 』を実行するためには実行許可を得る必要があります。アドインをインストール後、初めてエクセルを起動するとパスポートID登録ダイアログ が表示され、パス ポートIDを入力するとそのコンピュータでの実行が許可されます。パスポートIDによる実効許可はコンピュータごとに必要になります。コンピュータを変更した場合には新たにパスポートIDをご購入いただく必要があります。

同一コンピュータでもCPUやﾏｻﾞｰボードを変えたりするなどの改造を行なったり、ディスクをフォーマットまたは変更したりすると別コンピュータと認識される場合があります。その場合も別途ご購入していただく必要があります。


アドインの接続・解除・削除

●アドインの登録

アドインの登録はインストール時に自動的に行われますが、上手く登録されなかった場合、以下の手順で登録してください。

① 『 Dual Plus For Excel Pro 』はエクセルのアドインとして機能します。アドインを登録するには、エクセル起動後メニューバーの［ツール］-［アドイン］をクリックします。（一つ以上のブックが開かれていないと、アドインを選択することができませんので注意して下さい。）

② アドインダイアログボックスが開かれますので［参照］ボタンをクリックして、インストール先フォルダの DP4EPro.xla を選択し［OK］ボタンをクリックします。アドインダイアログボックスに 『 Dual Plus For Excel Pro 』 と表示され、チェックマークがつきますので［OK］ボタンをクリックしてダイアログを閉じます。

アドインがセットされると、DualPlusForExcelProツールバーが表示されます。これで、『 Dual Plus For Excel Pro 』を使用できる環境は整いました。

アドインファイルははデフォルトでは C:\Program Files\Dual Products\DualPlusForExcelPro フォルダにインストールされた DP4EPro.xla です。

● アドインの解除

アドインが登録されていると常にツールバーが表示されます。他の業務を行う上で邪魔になるような時に解除してツールバーが表示されないようにします。

① アドインを削除するには、エクセルのメニューバーの［ツール］-［アドイン］をクリックしアドインダイアログボックスを開きます。

② アドインダイアログボックス内の 『 Dual Plus For Excel Pro 』 のチェックマークを外し、［OK］ボタンをクリックします。

③ 解除を行なうとDualPlusForExcelProツールバーが削除されます。（ただし、アドインリストからは削除されません。）

エクセルのメニューバーの［ツール］-［ユーザー設定］でもツールバーを一時的に非表示とすることができますが、次回起動時に再び表示されてしまいます。 解除を行うと次に登録するまで表示されなくなります。

●アドインの削除

アドインの削除はアンインストール時に自動的に行われますが、上手く削除されなかった場合、以下の手順で登録してください。

① DP4EPro.xla が削除されていることを確認し、エクセルを起動しアドインダイアログを開き『 Dual Plus For Excel Pro 』をチェックします。アドインが見つからないのでエラーメッセージが表示されます。この時、リストから［削除する］を選択します。


ヘルプの表記

   ヘルプﾟでは解説を分かりやすくするため各種画面例を使用していますが、表示される入力項目はデータまたは作業状況により構成が変化します。

   このヘルプでの各種画面例は、なるべく多くの項目が表示されるよう構成されていますので、実際作業をするときにはこのヘルプ例通りに表示されるとは限りません。

以下のマークはそれぞれ次のような意味を持ちます。

ð 注意すべき事柄であることを示します。必ずお読み下さい。

ð 付加すべき一般的な情報であることを示します。

ð 知っておくと便利な情報である事を示します


Excel2007での注意

エクセル2003以前で作成されたブックを、「互換モード」のままエクセル2007上で実行 した場合にはうまく機能しない場合があります。Excel2007ではExcel2007ブック形式に変換した上で実行するか、一旦2007形式に変換後、再度「Excel97-2003ブック 」形式で保存してから実行するようにして下さい。


はじめに

   『 Dual Plus For Excel Pro 』をご利用頂きありがとうございます。

当社で日常的にエクセルを使用するに際して不便に感じる点を機能拡張したフリーアドイン『 Dual Tool 』を開発・提供していましたが、複雑化する様々な業務に対応するため、大幅な改良を行い、『 Dual Plus For Excel Pro 』としてリリースすることとしました。本アドインは 、正直なところ「なぜあの優れたエクセルに元々無いんだろう」と思うような機能を付け加えたものですが、複雑または大規模なシステムを扱っているヘビーユーザーには勿論、業務の引継ぎなどで他の人の作成したブックを扱う場合に欠かせないものとなることと思います。


エキスパートモード

エキスパートモードは、通常のエクセル操作では設定できない設定をできるようにしてあります。エキスパートモードにするには、 ［Shift］-[Ctrl]キーを押しながら、 [image] [image] [image] アイコンの何れかをクリックすると交互に切り替えることができます。エキスパートモードの時にはダイアログのタイトルに （！）のマークが付加されます。

シート管理での機能

① VeryHiddenのシートを扱うことができます。ショートカットメニューに「シート隠秘」が追加表示されます。 VeryHiddenシートは一覧の [image] 列に ［#］(ﾅﾝﾊﾞｰ)マークが付き、切り替えも[#]キーで行います。

② ［Shift］キーを押しながら[Space]キーを押して開かれるダイアログに「ユーザーインターフェースのみ」が追加されます。ユーザーインターフェースのみの保護が付いた場合は [image] 列に ：(コロン）が表示されます。

セル文字列による名前定義での機能

① 不可視の名前が扱えるようになります。ダイアログに「不可視とする」チェックボックスが表示されます。

名前リストでの機能

① 不可視の名前が扱えるようになります。ダイアログに「不可視とする」チェックボックスが表示されます。


シート管理

ブック内のシート数が多くなると、シートタグのクリック、CTRL-PageUp/PageDownまたはシート送りアイコンの位置で右クリックして一覧から選択する方法は結構面倒に感じます。また、保護の状況が一覧できないなど些細なことですが不便さを感じます。

ツールバーの [image] ボタンを押すと以下のようなダイアログボックスが表示されます。このアドインではシート名一覧を表示して、選択と同時に選択シートを表示することで内容を確認しながら選択でき、同時に属性の変更を行なうことが できます。

リスト上で右クリックしたときのショートカットメニュー

ダイアログはサイズを自由に変更できます。

シート管理では以下のことができます。

シートの閲覧と選択

シート選択は［↑］ ［↓］キーおよびマウスでシート名をクリックすることで行なうことができます。シートが選択されるとそのシートが前面に表示されます。

シートの順序変更

選択されているシートの順序を［ALT］キーを押しながら［↓］または［↑］キーを押すことで入換えることができます。 マウスで変更をする場合は、選択されている行を左クリックし、ボタンを押したままドラッグします。

シートの保護／解除

シートの保護属性をスペースを押すことで切り替えることができます。Shiftキーを押しながら[Space]キーを押すと以下のようなダイアログが表示され詳細な設定を行うことができます。

通常に保護されたシートは [image] 列に！(ｴｸｽｸﾗﾒｰｼｮﾝ) マーク が表示されます。パスワードで保護されたシートを解除する場合にはエクセル標準のパスワード 入力ダイアログが表示されます。

保護の列タイトル部で右クリックすると、以下のようなショートカットメニューが表示され、全シートに対して一括して保護設定を行うことができます。

シートの表示／非表示

シートの表示属性をテンキーの[＊](ｱｽﾀﾘｽｸ)キーまたは　［shift]-[：]で切り替えることができます。非表示のシートは [image] 列に＊(ｱｽﾀﾘｽｸ) マークが付きます。非表示属性の シートを選択すると強制的に表示属性になります。

表示の列タイトル部で右クリックすると、以下のようなショートカットメニューが表示され、全シートに対して一括して表示設定を行うことができます。

シートの削除

［Del］キーを押すと選択されているシートを削除することができます。［Del］キーでは、削除確認ダイアログが表示され、［Shift］-［Del］（［Shift］キーを押しながら［Del］キーを押す）では、確認ダイアログを表示せずに削除します。

シートの名前変更/シート見出しの色

リスト上の名前をダブルクリックすると以下のようなダイアログが表示され、シートの名前を変更することができます。

[シート見出しの色]ボタンをクリックすると、色選択ダイアログが表示され、シート見出しの色を選択することができます。

エクセル2007では色の選択は行えますが、色なしを選択することはできません。。

シート名でソートして並替え

シート名でソートしてシートを並べ替えます。ショートカットメニューのボタンをそのままクリックすると昇順、［Shift］ キーを押しながらクリックすると降順にソートします。

シートリストのコピー

シートリストをクリップボードにコピーします。

元のシートに戻って終了

［Shift］キーを押しながらダイアログのクローズボタンクリックすると、ダイアログを開いたときのシートに戻り、表示位置を戻します。

ダイアログを開いたシート以外でスクロールなどした状態は戻せません。

Excel2002以降で、シート見出しの色を設定した場合は、[№]列の部分が同色で塗り潰されます。

アクティブブックが変更されたとき、シートが挿入または削除されたとき、エクセルのシートタブで順序または名前が変更されたときには自動的にダイアログが閉じられます。 また、シート管理ダイアログを開いたままエクセルからシートの表示属性の変更やシート保護属性の変更を行った場合は、シート管理ダイアログに反映されません。一旦ダイアログを閉じて再表示してください。

      最後に非表示シートを選択した状態で、ダイアログを閉じると、直前の表示シートをアクティブシートにして閉じます。


セル情報の標示

セル情報の表示

セルには多くの設定が行われますが、それらの情報を一つひとつ確認していくのはかなり面倒です。 簡単に示せば以下のようになります。「セル情報表示」では、これらの情報を一度に表示することができます。ワードではポップヒントで同様なことができますが、なぜかエクセルに無いのが残念で作成しました。

セルの値 | 数式が設定されていると、数式バーには数式が表示されてしまうため、縮小した状態では値を確認できないため、縮尺を変更して確認 しなければなりません。
セルサイズ | 書式メニューの[行]-[高さ]:で行高、[列]-[幅]:で列幅を確認。ただし、結合セルに関しては左上のセルサイズしか得られませんので、足しあわさなければなりません。
書式 | 書式メニューの[セル]からダイアログを開き、各タブを切り替えて確認しなければなりません。
入力規則 | データメニューの[入力規則]でダイアログを開き、各タブを切り替えて確認しなければなりません。
条件付き書式 | 書式メニューの[条件付き書式]で確認しなければなりません。
ハイパーリンク | 挿入メニューの[ハイパーリンク]で確認しなければなりません。

ツールバーの [image] ボタンを押すと以下のようにアクティブセルの情報を示すダイアログボックスが表示されます。ダイアログを表示したままセルを移動すると新たなアクティブセルの情報に更新されます。

表示されたセル情報に不都合があった場合は、各項目タイトル名(「・書式」など）の上にマウスをのもって行くと、マウスアイコンが [image] に変化し、ダブルクリックするか右クリックすると該当するダイアログを開き修正することができます。

セル値（ダイアログタイトルの下の白色の部分）には、表示されている文字が表示されますが、セル値と本来の値が異なる場合は、セル値にマウスカーソルを当てるとツールチップに本来の値を表示します。セル幅が足りなくて ### で表示されてしまっている場合などは、ツールチップで本来の値を確認することができます。

セル情報からセルの塗潰しを変更する書式設定ダイアログを開くとパターンがうまく表示されません。 何も変更せずに[OK]ボタンを押すと塗りつぶしパターンが変更されることがあります。変更がない場合は[キャンセル]ボタンで終了してください。


セル文字列による名前定義

名前定義をする場合、範囲を指定して数式バーの左横にある名前ボックスで名前を入力するか、メニューの[挿入]-[名前]-［定義］を使用して設定するようになります。これらの方法で名前を付けるときに エクセルの優れた多様な機能を享受できません。そこで、先ずセル上に名前を入力しておいてから、順次範囲をしていき名前定義を行なおうと考えました。こうすればエクセルの優れた機能を存分に活用できます。Excel2007では、名前を「選択範囲から作成」機能が追加されていますが、本アドインの方が柔軟性に富んでいると思います。また、本アドインではシートの保護状態でも設定できるようにしてあります。

ツールバーの [image] ボタンを押すと以下のようなダイアログボックスが表示されます。

［名前の文字列範囲］

名前とする文字列が入ったセルの範囲を指定します。範囲は一行または一列でなければなりません。ダイアログの初期表示には直前の選択範囲が表示されます。ダイアログ表示前の選択範囲が単独の場合は自動的に一列または一行の範囲に拡張されます（[Shift]キーを押しながらアイコンをクリックすると拡張しません）。複数行または複数列が選択されている場合は一行または一列の範囲に縮小されます。選択範囲に空白セルが含まれた場合そのセルの部分は無視されます。

名前にはスペースを含んだりA1等セル参照名と重複する文字列を名前とすることはできません。

［名前付けする範囲］

名前付けする範囲は以下の３種類の方法から選択します。

① 順次範囲を指定する

定義直前に以下のようなダイアログが表示されますので、個々に範囲を選択しながら指定します。［この名前をﾊﾟｽ］は、現在の名前を定義せずに次の名前の定義に移ります。［すべて中止］は後に続く名前定義を含めて全てを中止します。 セル上の文字列が間違っていた場合など、セル城の文字列と違う名前としたい場合は名前を修正することができますが、セル上の名前と違った場合、後述の｢処理終了後のｾﾙ文字列｣の選択に拘わらずセル文字列は変更されません。

② 単一のセルに1：1で連続で名前付けする

［名前の文字列範囲］と１：１の関係で名前を定義します。定義される名前の範囲は常に単独セルになります。範囲の先頭を指定するとその位置から連続した範囲に定義していきます。範囲の先頭範囲として複数セルが選択された場合は、左上のセルを基準とします。
定義は［名前の文字列範囲］の選択方向（行または列）と同じ方向に連続して定義していきますが、［行列を入換えて名前付けする］がチェックされていると方向を変えて定義していきます。

下の図は名前のとする文字列がA1:A4に入力されていて、範囲の先頭にB1を選択したところです。この例では、B1に[名前１]、B2に[名前2] ・・・ B4に[名前4]の名前が付けられます。

③ 既定義を削除する

選択されると名前の定義は行なわず、既に定義されている名前の削除のみを行ないます。エクセルのメニューの[挿入]-[名前]-［貼り付け］のダイアログで［一覧の貼り付け］を行うと既に定義されている名前の一覧がセルに出力されます。これらの名前を使用すると簡単に複数の名前を削除することができます。

スペースを含んだりA1等セル参照名と重複する名前については削除できません。

［処理終了後のｾﾙ文字列］

処理の結果を知るために、処理が正常終了した名前に使用したテキストをグレイ表示または削除することができます。名前に使用できない文字などを使用していた場合は変化しませんのでチェックに役立ちます。［そのまま］を選択した場合は処理結果にかかわらず何も行ないません。

［シートに対する名前にする］

通常名前はブックに対して定義されますが、シートに対して定義する場合に使用します。

メニューの［ファイル］-［印刷範囲］-［印刷範囲の設定］で定義される名前 Print_Area はシートに対して付けられています。


テキストの縦位置の指定

セル内での縦位置を選択します。ユーザー設定によってボタンを表示することもできますし、エクセル2007では標準でリボン内に表示されていますが、水平方向に比べてそれほどの頻度が無いように思いますので、ドロップダウンメニューにしました。現在の選択状態はアイコンの反転で示されます。

  上詰め

セルの上側にテキストを配置します。

  上下中央揃え

セルの中央にテキストを配置します。

  下詰め

セルの下側にテキストを配置します。

  両端揃え

セル内に両端を揃えてテキストを配置します。

  縦方向に均等割付

セル内に均等にテキストを割り付けます。（＝両端揃えのような気がしますが、エクセルに選択肢があるので付けてあります。）


パスポートID 登録

パスポートID登録にはダイアログに表示されるユーザーIDが必要です。購入手続きおよびユーザーIDの通知が済むと、㈲デュアルよりパスポートIDが発行されます。

ダイアログは『 Dual Plus For Excel Pro 』アドインが登録され、パスポートIDが未登録のとき エクセルを起動すると表示されます。

このボタンを押すとクリップボードにユーザーIDがコピーされます。正確を期すためにもなるべくこのボタンを使用して取得して下さい。

送付されたパスポートIDをコピーした後、このボタンを押すと一度にパスポートID の各ボックスに入力することができます。正確を期すためにもなるべくこのボタンを使用して入力して下さい。コピーするパスポートIDは 英数字を―（ﾊｲﾌﾝ）で繋いだ　####-####-#### （＃には半角英数字が入ります）の形式でなければなりません。

パスポートIDを入力するとユーザーIDを取得したコンピュータ上のレジストリに登録されます。パスポートIDはコンピュータごとに異なり限定されます。別なコンピュータで実行する場合は別途購入して登録する必要があります。パスポートIDは1購入に対して一度だけ発行されます。

同一コンピュータでもCPUやﾏｻﾞｰボードを変えたり するなどの改造を行なったり、ディスクをフォーマットまたは変更したりすると別コンピュータと認識される場合があります。その場合も別途ご購入していただく必要があります。


ブックマーク

ブック内の 参照箇所が多くなると、ブックやシートの切り替え、そしてスクロールと、その場所への移動時間が多くなります。Ｗｏｒｄにはブックマークがあるのになぜかエクセルに無いのが残念で作成しました。ブックマークを使用すると簡単にそのセルへ移動し、また元に戻ることができます。

ツールバーの [ブックマーク] ボタンを押すと以下のようにメニューがプルダウンされます。

ブックマークが非表示シートにある場合は、メニューにジャンプ先は表示されます選択することはできません。

ブックマークを設定したい範囲を選択し、「 [image] ブックマークの追加」ボタンをクリックすると以下のようなダイアログボックスが表示されます。

選択された範囲の左上のセルに文字列テキストが表示されていると、ダイアログにはマーク名としてそのテキストが表示されます。テキストが表示されていない場合は、範囲の左上セルのアドレス（[ブック名]シート名！セルアドレスの形式）が表示されます。

［直前セルに戻る］

ブックマークにジャンプを行うか 式の参照元一覧の[ここに移動] ボタンを使用すると表示され、ジャンプ前のアドレスが登録されます。

ブックマークの削除

［Ｓｈｉｆｔ］キーを押しながらブックマーク名をクリックするとブック名は削除されます。

ブックマークの置換え

［Ｓｈｉｆｔ］-{Ctrl]キーを押しなが リスト上の名前をクリックすると、そのボタンの設定範囲を現在の選択範囲に置き換えます。ブックマークの置換えダイアログが表示されますので名前の変更も行えます。

ブックマークの全置換え

［Ｓｈｉｆｔ］キーを押しながら「ブックマークの追加」ボタンをクリックすると、既に設定されているブックマークを全て破棄して、今回のブックマークのみがメニューに登録されます。作業の切り替えなどで、既に設定されたブックマークを破棄したいときに使用します。

ブックマークはエクセルが起動されている間だけ有効で、次回起動時には全て破棄されます。


ヘルプ表示とバージョン情報

ヘルプの表示

ボタンをクリックするとこのヘルプウィンドウに目次を表示します。［シート管理］などのダイアログが表示されているときにF1キーを押すと関連部分のヘルプを表示します。

バージョン情報

[Shift]キーを押しながらボタンをクリックするとバージョン情報ダイアログが表示され、現在お使いのアドインのバージョンおよびユーザーIDなどが取得できます。

『 Dual Plus For Excel Pro 』の最新版は、弊社HP　http://www.u-dual.co.jp/　のサポートページからバージョンアップツールをダウンロードすることにより入手できます。


使用条件について

本ソフトウェアをご使用するには以下の条件に従って頂く必要があります。未登録でご使用なさる場合も従って頂きます。従えない場合は、ご使用をご遠慮下さい。

１．著作権について

本ソフトウェアの著作権、その他知的所有権等の一切の権利は、㈲デュアルがその権利を保有しています。

２．使用制限

本ソフトウェアの使用は、ユーザーIDを得たコンピュータに登録されたユーザー名と同一のユーザー名を持つコンピュータにおいて、登録者の管理下で使用する場合に限ります。未登録状態でのご使用は、本ソフトウェアの許容する期間に限ります。

３．禁止事項

本ソフトウェアを第三者に販売することはできません。また、本ソフトウェアの翻案またはリバースエンジニアリングをしてはならないものとします。

４．免責事項

本ソフトウェアに関していかなる保証も行いません。本ソフトウェアを使用しまたは運用した結果、直接または間接的に生じる損害に関して一切責任を負わないものとします。

５．サポート

ユーザー登録された方に電子メールにて行います。サポートを受ける為には、メールアドレス、氏名、ユーザーIDおよびサポートID（ﾊﾟｽﾎﾟｰﾄID）が必要です。


名前リスト

定義した名前が多くなるとエクセルの挿入メニューの[名前]-[定義]で確認するのは結構面倒です。名前リストでは簡単に一覧がすることができる上、シート保護状態でもリスト上の名前を選択すると名前範囲をを表示します。また、シートの削除やセルの削除で参照範囲が無くなり#REFエラーとなっている名前も容易に見つけることができ削除も可能です。Excel2007では、「名前の管理」が追加されましたので同様なことはできますが、本アドインではシート保護状態でも削除や変更ができるようにしてあります。

ツールバーの [image] ボタンを押すと以下のようなダイアログボックスが表示されます。

リスト上で右クリックしたときのショートカットメニュー

名前は状況により次の色で分類表示されます。黒以外の文字色の場合に名前に位置付けるとダイアログ右下に状況の解説が表示されます。

       赤色 ： 参照範囲が存在せず #REFエラーとなっている名前。

    濃黄色 ： 参照範囲外部ブックなどで、そのブックが開かれておらず参照できない名前。

   灰色 ： 保護されたシート上にある名前。

       黒 ： 上記以外の名前。

ダイアログはサイズを自由に変更でき、列幅も境界部をドラッグすると変更できます。また、列のタイトル部をクリックすることで、列の値に応じてソートして表示できます。

名前リストでは以下のことができます。

名前の削除

［Del］キーを押すと選択されている名前を削除することができます。

名前定義変更

リスト上の名前をダブルクリックすると以下のようなダイアログが表示され、名前の定義を変更することができます。

エキスパートモードではチェックボックスが追加され名前の不可視属性も扱うことができます。

リストのコピー

表示されているリストをクリップボードにコピーします。

このセルに移動

表示されている名前の範囲に移動してダイアログを閉じます。移動前の位置はブックマークに登録されます。

［ブック全体］

チェックするとブック全体の名前の一覧を表示します。


外部参照セルの選択

エクセルの編集メニューの[ジャンプ]－[セル選択]ボタンから色々なセルを選択できますが、残念ながら外部セルを参照したセルを選択する手段はありません。ブックを開いたときに良くリンクの更新を行うかどうかの問い合わせが出ますが、それが何処のことなのかを知るには結構苦労します。そこでこの機能を作成しました。

・他のシート、他のブックを直接参照しているセルを選択しますが、名前を介して外部セルを参照しているセルは選択されません。

・ リンク更新の問い合わせは数式だけでなく、名前などで参照されたときにも問い合わせが行われます。数式に外部参照があった場合はこの機能で見つけることができますが、名前などで参照していたときには名前リストなどを利用して見つける必要があります。


定型句

セルに同じ文字を何度も入力したいときが良くあります。連続的に入力するならクリップボードで良いのですが、得てして連続していません。Ｗｏｒｄには定型句があるのになぜかエクセルに無いのが残念で作成しました。 定型句ではセルにその値を入力したり、既に入力されている文字列に定型句を追加することができます

ツールバーの [定型句」 ボタンを押すと以下のようにメニューがプルダウンされます。

定型句は、ボタンをクリックするとセルまたはテキストボックス（テキストボックスの編集状態では入力されません。テキストボックスは選択状態にして下さい。）に入力されます。[Ctrl]キーを押しながらボタンをクリックするとセルまたはテキストボックスの文字列の終わりに定型句が追加されます。

一時定型句

一時定型句の追加

一時定型句は エクセルを開いている間だけ有効な定型句です。たまたま、同じ入力が繰り返されるような場合に登録してして使用します。意図的に削除等をしない限り残っていますのでいつでも使用することができます。

一時定型句を追加するには、定型句としたい文字列の入力されたセル範囲を選択してから、「定型句の設定」から「 [image] 一時定型句の追加」ボタンをクリックします。複数行を選択範囲とすることができますが、列は一列として下さい。

一時定型句の削除

一時定型句を削除するに、[Shift]キーを押しながらボタンをクリックします。クリックされた定型句がメニューから削除されます。

一時定型の全置換え

［Ｓｈｉｆｔ］キーを押しながら「一時定型句の追加」ボタンをクリックすると、既に設定されている 一時定型句を全て破棄して、今回の一時定型句のみがメニューに登録されます。作業の切り替えなどで、既に設定された一時定型句を破棄したいときに使用します。

固定定型句

固定定型句はデータベースに登録され、エクセル起動時には常にメニューにセットされます。

固定定型句はAccessのデータベース、C:\Documents and Settings\ユーザー名\Application Data\DualPlusForExcelPro\DP4EPro.mdb の FixedTextClass および FixedTextItems テーブルに格納されています。

定型句の取り込み

固定定型句は、エクセルのシートから読み込みデータベースにセットすることができます。各列をカテゴリーに対応させ、最初のセルがカテゴリー名となります。詳しくは、後述の「定型句一覧の貼付け」を参照して下さい。カテゴリーは最大20まで扱うことができます。

取り込みデータの位置は任意のセルでかまいませんが、連続した範囲で選択する必要があります。選択にはいづれかのデータをカレントセルとし、編集メニューの[ジャンプ]-[セル選択」ボタンで表示されるダイアログの[アクティブセル領域]を選択して選ぶようにして下さい。選択範囲の先頭行の文字がカテゴリー名になります。空白は使用できません。

定型句一覧の貼付け

定型句一覧の貼り付けを行うと、新しいブックを開き、データベースに登録されている定型句を A1セルからは貼り付けます。1行目にはカテゴリー名が太字で、各定型句はインデントされて出力されます。

・貼り付けられるのは、固定定型句のみです。
・太字や、インデントは見易いように出力されているだけで、取り込み時には必要ありません。
・定型句に空白は設定できません。


式の参照元一覧

エクセルには、分析ツールが用意され、参照元や参照先へのトレース矢印を引いたり、数式の検証機能で式を追跡する機能もあるのですが、実際に数式を分析する上ではなかなかしっくりしませんでした。そこで、参照元のアドレスと値を一覧表示し、アドレスを選択するとそのアドレスへジャンプして 式の構成要素を閲覧できるようにしました。式の閲覧であちこち表示を切り替えたとしても、終了時には元にもどれ、状況によっては参照箇所に移動できる機能をつけています。

式は、数式だけでなく入力規則や条件付書式にも使用されるのでそれらも参照できるようにし、判定結果も判別できるようにしました。 同時に、数式でIF文を多用していると、ネストの関係が分かりづらいので、インデント表示して分かり易くしました。

ツールバーの [image] ボタンを押すと以下のよう なダイアログが表示され、アクティブセルの数式と参照元のアドレスと値を表示します。一覧ではダイアログを開いたアドレスの№を＊(ｱｽﾀﾘｽｸ)で示します。ここを選択するといつでも元に戻れます。 数式中のアドレスにキャレットを持っていくか、下側ペインの一覧で参照元のアドレスを選択すると、選択されたセルをカレントセルとし、上側ペインの式中の該当変数(アドレス）箇所を青の太字とします。

また、数式中の一部を選択すると、選択範囲を評価し値をツールチップテキストでポップアップ表示します。

入力規則および条件付き書式の場合は、以下のように判定結果が最上行の値列に[TRUE]または[FALSE]で表示されます。条件付き書式で[TRUE]の場合は、設定されている書式で表示されます。

ダイアログはサイズを自由に変更できます。上下ペインの大きさ、列幅も境界部をドラッグすると変更できます。 また、アドレス部でマウスの左ボタンを押したままにすると、その間アドレスの詳細をダイアログの左下に表示します。

［個々のセル表示］

参照アドレスに範囲が含まれているときに有効になります。チェックすると範囲内のセルを個々に表示します。

［式は右端で折返す］

式が長い場合にダイアログからはみ出してしまいます。ダイアログのサイズを変更せずに全体を見たいときにチェックします。

［ここに移動］

選択されているアドレスをカレントセルとしたいときにクリックします。移動すると移動前のアドレスは自動的にブックマークの「直前のセルに戻る」に登録されます。移動後に容易に元の位置に戻ることができます。

数式内に間接参照を行うINDIRECT関数が使用されている場合は、下側ペインのアドレスにINDIRECT関数部分も表示され、通常の参照元と同じように値を表示します。

参照元がエラーだったり、外部ブックが開かれていないときなどには、参照元が表示されない場合があります。


数式および値の貼り付け

  数式の貼り付け

この機能は、エクセルのメニューの［編集］-［形式を指定して貼り付け］で［数式］を選択したときと同じですが、結構頻度が高いのでワンクリックで貼り付けできるようにボタンを割り当てています。

  値の貼り付け

この機能は、エクセルのメニューの［編集］-［形式を指定して貼り付け］で［値］を選択したときと同じですが、結構頻度が高いのでワンクリックで貼り付けできるようにボタンを割り当てています。また、結合セルへの貼り付けでは、 エクセルでエラーとなるものも強制的に貼り付けられるように機能拡張されています。

エクセル2007では使用が変更されたようで、結合セルに張り付けるとテキストボックスになってしまいます。現在（2008/8)は対応方法が見つかっていません。


書式リスト

セルの書式の一覧を表示します。エクセルを使用していると「表示形式を追加できません。」のエラーメッセージが表示され、どうにもならないときがあります。解決方法は書式を減らすことですが、どんな書式が設定されているか、何が余分なのかがわかりません。そこで、この機能を作成しました。

ツールバーの [image] ボタンを押すと以下のようなダイアログボックスが表示されます。

書式を取得する範囲を「現在までに使用した範囲のセル」または「現在の選択範囲」から選択します。

範囲が選択されると、選択された範囲の書式が以下のように表示されます。

リストには、セルの列、行、表示書式、フォント名、フォントサイズ、太字、斜体、下線、取り消し線、上付き、下付き、横位置、縦位置、インデント、方向、文字色、塗りつぶし、結合（代表セルには行数×列数、その他には代表セルアドレスを表示）、配置、保護、数式表示、罫線（上下左右）の属性を表示します。

表中のセルをクリックするとエクセルの該当セルをアクティブセルとします。また、セルをダブルクリックすると、クリックした列位置の項目に応じたダイアログボックスが表示され属性を変更することができます。

マウスを右クリックすると以下のようなショートカットメニューが表示されリストに対する操作を行うことができます。

フォントサイズ

選択されたフォントに表示を切り替えます。切り替え時には列幅は選択されたフォントにより初期化されます。

このセルと同書式のセルを非表示

選 現在選択中のセルとセルアドレス以外が異なるセルの行を非表示とします。非表示した状態ではショートカットメニューの項目は「すべてのセルを表示」となり元に戻すことができます。

リストのコピー

表示されているリストをクリップボードにコピーします。

このセルに移動

表示されている名前の範囲に移動してダイアログを閉じます。移動前の位置はブックマークに登録されます。

書式リストからセルの塗潰しを変更する書式設定ダイアログを開くとパターンがうまく表示されません。 何も変更せずに[OK]ボタンを押すと塗りつぶしパターンが変更されることがあります。変更がない場合は[キャンセル]ボタンで終了してください。


縦方向に結合

エクセルのは「横方向に結合」機能はありますが、「縦方向に結合」機能が無いため作成しました。

「横方向に結合」はツールメニューの［ユーザー設定］ で表示されるダイアログの[コマンド]タブの分類の[書式]にアイコンが用意されています。


著作権

本製品は、日本国著作権法および国際条約により保護されています｡ 本製品の全部または一部を無断で複製したり、無断で複製物を頒布すると、著作権の侵害となりますのでご注意下さい。

本製品には以下の著作物が含まれています。

DP4EPro.xla | Copyright (C) 2008 有限会社 デュアル
DP4ExcelPro.dll | Copyright (C) 2008 有限会社 デュアル
vsflex8l.ocx | VS-FlexGrid Pro 8.0J Copyright (C) 2001-2003 ComponentOne LLC
その他 | 著作権表示が義務付けられてはいませんが、弊社の立場で再配布を許可された著作物


非ロックセルの選択

エクセルの編集メニューの[ジャンプ]－[セル選択]ボタンから色々なセルを選択できますが、残念ながらシートを保護したときに入力可能なロックを解除したセルを一覧できる手段はありません。 入力可能範囲を知るには結構苦労します。そこでこの機能を作成しました。

ボタン押下時に単独セル（結合セルも単独とみなします）を選択している状態では、使用されているセル範囲（A1から編集メニューの[ジャンプ]-[セル選択」ボタンで[最後のセル]で示される範囲）を 対象とします。複数セルを選択している場合は選択セル範囲を対象とします。