概　要

『ExcelでFramePro』は 手軽にフレーム（平面骨組み解析）計算を行なえるように開発されたExcelのアドインです。一般的なフレーム計算ソフトは各種条件をExcelなどで計算した後、各値を入力して計算、出力させますが、『ExcelでFramePro』ではExcelに計算機能を持たせることにより条件計算、計算から出力までをExcelのみで完結させることを目指しています。しかも、計算は部材バネや温度による線膨張も扱える本格派です。

使い方は通常のExcelと何ら変わりありません。節点、部材、荷重、支点条件などフレーム計算で使用する入力用のシートに値を入力してツールバーボタンを押せば計算結果が出力されます。入力用シートのデータは他のシートで計算された値へのリンクや計算値とすることができますので、条件計算と連動させることができます。計算結果は変位、支点反力および部材応力がExcelのセルに表形式で、変位図および応力図がExcelの図として出力されます。

『ExcelでFramePro』の最も特徴的な機能としてExcelブックごとに条件描画用インナーウィンドウが用意され、Excelへの入力に連動して節点、部材、荷重および支点条件など構成図をリアルタイムに描画します。図は拡大縮小、スクロールを行なうことができますので、操作はExcelそのままに入力状況を確認しながら入力を行なうことができます。

一度でもフレーム計算をしたことのある方なら、すぐに便利さを納得していただけるものと思います。

Copyright(C) 2005 Dual Ltd.　 Dual


必要な実行環境

『ExcelでFramePro』を実行するには、以下の環境が必要です。

● ハードウェア

Windows98/ME/2000/XP日本語版が動作する環境。

2MB以上の空き領域を持つハードディスク。必要メモリ128ＭＢ（256MB以上推奨）。

解像度800×600以上、カラーパレット256色以上（High Color16ビット以上推奨）表示可能なディスプレイ。

● ソフトウェア

Windows98/ME/2000/XP日本語版

＊Windows2000はService Pack 3 以上が必要です。

＊Windows2000/XPにインストールするには管理者権限でログオンする必要があります。

＊制限ユーザーではアドインは使用できません。

Microsoft Excel 2000以降

実行するにはExcelのツールメニューの［マクロ］-［セキュリティ］の［セキュリティレベル］は［中］または［低］とし、［信頼のおける発行元］タブで［組み込み済みのアドインとテンプレートをすべて信頼する］をチェックしてください。Excel2002以降では［Visual Basicプロジェクトへのアクセスを信頼する］もチェックしてください。

● 実行許可

『ExcelでFramePro』を実行するためには実行許可を得る必要があります。実行許可にはご購入形態により以下の２種類の方法があります。

① プロテクションキーによりコンピュータを限定せずに使用する。

プロダクツに同梱される『ExcelでFramePro』用のプロテクションキーが必要です。キーをUSBポートに接続し、デバイスドライバをインストールしなければなりません。詳細はプロテクションキーの設定を参照して下さい。

② パスポートID によりコンピュータを限定して使用する。(シェアウェアタイプ）

アドインをインストール後、初めてExcelを起動するとパスポートID登録ダイアログが表示され、パスポートIDを入力するとそのコンピュータでの実行が許可されます。パスポートIDによる実効許可はコンピュータごとに必要になります。コンピュータを変更した場合には新たにパスポートIDをご購入いただく必要があります。

同一コンピュータでもCPUやﾏｻﾞｰボードを変えたり するなどの改造を行なったり、ディスクをフォーマットまたは変更したりすると別コンピュータと認識される場合があります。その場合も別途ご購入していただく必要があります。


ユーザー登録

パスポートID 登録

パスポートID登録はコンピュータ限定版（シェアウェアタイプ）をご購入した場合に必要になります。（プロテクションキーを使用する場合はパスポートID登録は必要ありません。）

パスポートID登録にはダイアログに表示されるユーザーIDが必要です。購入手続きおよびユーザーIDの通知が済むと、㈲デュアルよりパスポートIDが発行されます。

ダイアログは『ExcelでFramePro』アドインが登録され、パスポートIDが未登録のときExcelを起動すると表示されます。

このボタンを押すとクリップボードにユーザーIDがコピーされます。正確を期すためにもなるべくこのボタンを使用して取得して下さい。

送付されたパスポートIDをコピーした後、このボタンを押すと一度にパスポートID の各ボックスに入力することができます。正確を期すためにもなるべくこのボタンを使用して入力して下さい。コピーするパスポートIDは 英数字を―（ﾊｲﾌﾝ）で繋いだ　####-####-#### （＃には半角英数字が入ります）の形式でなければなりません。

パスポートIDを入力するとユーザーIDを取得したコンピュータ上のレジストリに登録されます。パスポートIDはコンピュータごとに異なり限定されます。別なコンピュータで実行する場合は別途購入して登録する必要があります。パスポートIDは1購入に対して一度だけ発行されます。

同一コンピュータでもCPUやﾏｻﾞｰボードを変えたり するなどの改造を行なったり、ディスクをフォーマットまたは変更したりすると別コンピュータと認識される場合があります。その場合も別途ご購入していただく必要があります。


アドインの登録と削除

アドインの接続と解除

●［COMアドイン］ メニュー

  ［COMアドイン］のメニューは必ずしも必要ありませんが、メニューに追加しておくとアドインの接続・解除を切替えて柔軟に使用できます。
  Excelの［ツール］メニューに［COMアドイン］が表示されていない場合は以下の手順で追加することができます

① ［ツール］ メニューの ［ユーザー設定］ をクリックします。

② ［ユーザー設定］ ダイアログ ボックスで ［コマンド］ タブをクリックし、［分類］ ボックスの一覧の ［ツール］ をクリックします。

③ ［コマンド］ ボックスの一覧の ［COM アドイン］ をクリックし、ボタンを押したままメニュー バーの ［ツール］ メニューにドラッグします。［ツール］ メニューが表示されたら、［COM アドイン］ コマンドを追加する位置をポイントし、マウスのボタンを離します。

④ ［ユーザー設定］ ダイアログ ボックスで ［閉じる］ をクリックします。

● アドインの接続・解除

① ［ツール］ メニューの ［COM アドイン］ をクリックします。

② ［使用できるアドイン］ ボックスの一覧で、［ExcelでFramePro］をチェックすると使用可能となり ツールバーが表示され、チェックを外すと一時的に解除されツールバーとFrameメニューが非表示となります。

■通常アドインはインストールするとメニューに[COMアドイン］が追加されていなくても自動的に接続されますが、何か障害があると接続でき ないケースがあります。その場合上記ダイアログの［削除ボタン］でアドインを削除後、［追加ボタン］でインストール先フォルダ（デフォルトでは C:\Program Files\Dual Products\ExcelでFramePro）にあるEFPro.dllを追加して下さい。

  Excel 2002以降ではインストールの前にExcel のヘルプメニュー［バージョン情報］の［使用できないアイテム］ボタンで表示されるダイアログに『ExcelでFramePro』が表示されていた場合は有効として、Excelを閉じて下さい。

■アドインを完全に削除するにはアンインストールする必要があります。解除をしてもファイルや設定はコンピュータ上に残っています。

■アンインストールする前に必ずアドインを解除して下さい。先にアンインストールを行なうとツールバーやメニューが残ったままでCOMアドインリストに『ExcelでFramePro』が表示されなくなります。
   もし先にアンインストールしてしまったときは、Excelの［ツール］メニューの［ユーザー設定］の［ツールバー］タブから『ExcelでFramePro』のツールバーを削除できます。また、［Frame］メニューはマウスで［ユーザー設定］ダイアログにドラッグしてマウスを離すと削除できます。


ご利用にあたって

本アドインは、利用者としてWindowsの初歩的な操作ならびにExcelの基本的な操作を理解し、フレーム（骨組み）計算に関しては十分な知識を有するエンジニアを対象としています。

本アドインでは状況によりExcelの入力規則の設定を含め様々なエラーメッセージ等を示しますが、これらはシステムが判断できる範囲の整合性の矛盾点を示すに過ぎず、本質的な原因を示すものではありません。したがって、これらのメッセージが示されなかったとしても、計算結果の正当性を保証するものではありません。また、一部には初期値が自動的にセットされるケースもありますので、入力データおよび計算結果はご利用される方が必ず確認するようにして下さい。


Excel2007での利用上 の注意

本アドインでは応力値の表示で文字の回転を行うため、ワードアートを使用していますが、Excel2007で仕様が変更されたためか、Excel2007で作成し保存したものは（Excel2007形式、97-2003形式を問わず）、旧バージョンのExcelでは上手く扱えません。（2008/7/9現在）

計算ﾊﾞｰｼﾞｮﾝ | 保存形式 | 開くﾊﾞｰｼﾞｮﾝ | 結果
2000-2003 | 97-2003 | 2000-2003 | OK
2000-2003 | 97-2003 | 2007 | OK
2007 | 2007 | 2007 | OK
2007 | 97-2003 | 2007 | OK
2007 | 97-2003 | 2000-2003 | OUT
2007 | 2007 | 2000-2003 2007ｺﾝﾊﾞｰﾀ使用 | OUT


ヘルプの表記

   ヘルプﾟでは解説を分かりやすくするため各種画面例を使用していますが、表示される入力項目はデータまたは作業状況により構成が変化します。

   このヘルプでの各種画面例は、なるべく多くの項目が表示されるよう構成されていますので、実際作業をするときにはこのヘルプ例通りに表示されるとは限りません。

以下のマークはそれぞれ次のような意味を持ちます。

ð 注意すべき事柄であることを示します。必ずお読み下さい。

ð 付加すべき一般的な情報であることを示します。

ð 知っておくと便利な情報である事を示します


解析方法

変位法により平面骨組み構造の解析を行ないます。平面骨組み構造の弾性挙動は、全節点のたわみ量 Uｘ，Uy および、たわみ角Uθ を求めることによって知ることができます。部材の両端をそれぞれ I端、J端として両端に働く部材力と変位量を示します。なお、計算の詳細については各種関連書籍等を参照して下さい。


座標系

● 全体座標系

構造物の節点に対しては以下のような座標系をとります。

● 部材座標系

荷重の入力に対しては以下のような座標系を取ります。

● 構造座標系

   斜め部材等にX,，Y座標方向に荷重を載荷したいときにはこの座標系を使用して作用方向を指定します。作用方向は鉛直方向および水平方向を選択することができます。また、構造座標系は作用方向だけに適用され、作用位置は部材座標に従います。

構造座標系は［鉛直方向集中荷重］および［鉛直方向分布荷重］に対して指定することができます。

● 変位に対する座標系

   変位は全体座標系の正に変位する場合に正で出力されます。回転変位量は時計回りに回転する場合に正で出力されます。

● 反力に対する座標系

   反力は全体座標系の正の方向に反力が働く場合に正で出力されます。曲げモーメントは時計回りに反力が働く場合に正で出力されます。

● 応力に対する座標系

   ① 曲げモーメント

曲げモーメントは左をI端、右をJ端とした梁を考えたとき、上端に圧縮、下端に引張が生じるようなモーメントを正で出力します。

   ② せん断力

ひとつの梁と考えたとき以下の図のようになります。

   ③ 軸　力

引張を正、圧縮を負で出力します。


使用上の制限

項 目 |  | 制 限 | 摘 要
扱いデ｜タ数の制限 | 節点 | 2≦n≦300 | データブック作成時の制限。計算時は各シートの名前 FrameDataArea の範囲を対象とします。
 | 部材 | 1≦n≦300 | 〃
 | 支点 | 1≦n≦100 | 〃
 | 荷重 | 1≦n≦300 | 〃
 | 節点荷重 | 1≦n≦100 | 〃
 | 着目点 | n≦79 （8） | 一部材に対する制限で、値は分割による着目点。（）内の値は位置を任意に指定する場合の制限。
作図サイズの範囲 | 作図幅 | 30mm≦W≦1000mm |
 | 最大応力値の幅 | 1mm≦W≦100mm |
 | 最大変位量の幅 | 1mm≦W≦100mm |
 | 図ﾀｲﾄﾙとの間隔 | 1mm≦W≦100mm |
 | 次図ﾀｲﾄﾙとの間隔 | 0m≦W≦99m |

■ 扱いデータ数の制限は入力可能な値を示しています。お使いのコンピュータにより制限数まで使用した計算を実行できない場合があります。


メニュー と ツールバー

アドインが接続されるとExcelメニューの［データ］と［ウィンドウ］の間に［FRAME]が追加され、『ExcelでFramePro』用のツールバー表示されます。

ﾃﾞｰﾀ用ブック作成 | 『ExcelでFramePro』用のデータブックを新規に作成します。オプションで指定された扱いデータ数に基づいて入力欄が作成され、関数、入力規則および各書式が設定されます。 ブックには ［節点ﾃﾞｰﾀ］、［部材ﾃﾞｰﾀ］、［支点ﾃﾞｰﾀ]、［荷重ﾃﾞｰﾀ］、［節点荷重ﾃﾞｰﾀ］のシートが作成されます。 通常数秒で作成されますがコンピュータによってはかなり時間を要する場合があります。
* 構成図の表示 | データブックに対して構成図ウィンドウを表示、または非表示とします。構成図ウィンドウが表示されているときにはボタンは押された状態になります。
* 計算開始 | フレーム計算を開始します。計算に先立ってデータチェックが行なわれ、不都合なデータがあるときはエラーメッセージを表示します。 計算が完了すると、オプションの設定により結果を［計算結果］および［計算結果図］シートに出力します。
* オプション | 『ExcelでFramePro』に関する各種設定を行ないます。
トピックの検索 | 『ExcelでFramePro』のオンラインヘルプを表示します。ヘルプは構成図ウィンドウやオプションダイアログがアクティブなときに [image] キーを押すことで該当する部分のヘルプを表示することもできます。
バージョン情報 | 使用している『ExcelでFramePro』のバージョン情報、著作権、使用許諾者の氏名と会社名およびサポートIDを表示します。

■ * の記されたボタンはアクティブブックが 『ExcelでFramePro』のときのみ有効となります。

■ ［データ用ブック作成］および［計算開始］を行なうとExcelのアンドゥバッファはクリアされ実行以前の状態には戻れなくなります。

■ Excelのブックを閉じようとして確認メッセージで［ｷｬﾝｾﾙ］ボタンで中止した場合は、* の記されたボタンは無効となります。再度有効とするには一旦他のブックをアクティブにした後、再び元のブックをアクティブにして下さい。ブックがひとつしか開かれていない場合は、ブックを新規作成しすぐに閉じることで有効にできます。


共通事項

データ入力シートに関して共通な部分をここに示します。

● 有効データ範囲

計算では、各シートに設定されている FrameDataArea のExcelの名前範囲にあるデータのみが対象となります。データが入力されていても名前の範囲外にあるデータは使用されませんので注意して下さい。

■ データは名前の範囲内に有れば自動的に設定される列や行に拘わらず自由にシート内にレイアウト配置できます。ただし、範囲内の構成を変更することはできません。

■ 名前の範囲外のデータは使用されないということは、逆にいえばトライアルを行なうときに、暫定的に使用したデータなどを範囲外に退避しておけるということでもあります。

● 有効データ範囲の確認

名前の範囲を確認するには以下の方法があります。

■ 名前ボックスから確認する

Excelウィンドウの左上にある名前ボックスの [image] ボタンをクリックして表示されるプルダウンメニューからFrameDataArea を選択すると、その範囲が反転表示されます。

■ ［挿入］メニューの［名前］で確認する

Excelの［挿入］メニューの［名前］-［名前］-［定義］で表示されるダイアログで FrameDataArea を選択すると、その範囲のアドレスが参照範囲として表示されます。カーソルを参照範囲位置に移すと範囲がアニメーション枠で囲まれます。

● 有効データ範囲の拡張

データブック作成で指定したデータより多くのデータを入力しなければならなくなったときは、有効データ範囲を拡張しなければなりません。範囲を拡張するには以下の方法があります。

■ 中間に行を挿入して拡張する

FrameDataArea 範囲を選択しマウスの右ボタンをクリックします。挿入方向選択ダイアログで［下方向にシフト］を選択すると範囲を拡張することができます。

■ ［挿入］メニューの［名前］で拡張する

Excelの［挿入］メニューの［名前］-［名前］-［定義］で表示されるダイアログで FrameDataArea を選択し参照範囲のアドレスを変更します。

■ 各セルには誤入力を防ぐため入力規則および条件付き書式が設定されています。範囲を拡張した場合でも各設定は変更されませんので、元の範囲を超える値は入力できなかったり赤字で表示されたりする場合があります。元の範囲を超える値を入力するには各設定を変更するか削除しなければなりません。ただし、削除した場合は適切なチェックは行われませんので十分注意して下さい。

■ 範囲を拡張する場合は、オプションで扱いデータ数を指定して新規にデータブックを作り、元のブックからコピー＆ペーストするのが最も安全な方法です。ただし、そのまま貼り付けると入力規則や条件付書式もコピーされてしまいますので、貼り付けは値のみを貼り付けて下さい。

● データNo.

各データのデータ番号は、範囲の先頭行を1として順次付けられます。部材データで参照する節点番号など他のデータ番号を参照する時には、この内部的な番号として判断されます。

入力シートのデータ範囲には番号が振られていますが、これは分かり易くするために振られているだけです。範囲拡張のために行を挿入した場合など間違え易くなるので注意して下さい。

● 入力時のメッセージ

各データで幾つかの項目ではデータ範囲の先頭行のセルに位置付けるとメッセージが表示されます。メッセージはExcelの入力規則により表示しています。以下のメッセージは部材データの結合条件入力時時に表示されます。

● シート保護

データブックはオプション設定でデータ保護を解除していない限り、データブック作成時に各シートはパスワードなしで保護され、データ部以外は入力できません。前述、データ範囲拡張などを行なう場合にはシートの保護を解除しなければなりません。


予約シート

   『ExcelでFramePro』では次のシート名を予約しています。他の目的でこれらのシート名を使用しないで下さい。シートの順序やシートの追加は自由です。

入力用 | 節点ﾃﾞｰﾀ | 節点データ入力用シート。
 | 部材ﾃﾞｰﾀ | 部材データ入力用シート。
 | 支点ﾃﾞｰﾀ | 支点データ入力用シート。
 | 荷重ﾃﾞｰﾀ | 荷重データ入力用シート。
 | 節点荷重ﾃﾞｰﾀ | 節点荷重データ入力用シート。
結果用 | 計算結果 | 計算結果出力用シート。計算後作成されます。
 | 計算結果図 | 計算結果図出力用シート。オプションで別シートに作図が選択された場合に作成されます。

結果用シートはオプションの選択により、計算に先立って一旦削除されます。結果用シートを参照した関数を使用すると再度計算したときに参照エラーとなりますので注意して下さい。


構成図ウィンドウ

   ［構成図の表示］ボタンをクリックすると現在アクティブな『ExcelでFramePro』用ブックの構成図を表示します。構成ウィンドウが表示されていると、メニューのアイコンまたはツールバーボタンは押された状態になります。

   構成図ウィンドウは各『ExcelでFramePro』用ブックに対して個々に表示されます。作図スケールは入力されたデータがウィンドウ内に納まるように自動的に決定されます。また、計算が実行されると構成図ウィンドウは自動的に閉じられます。

構成図はデータシートと連動しており、データを入力すると同時に描画します。また、各データ位置がアクティブセルになると対応する部分が紫色で表示されます。構成図の表現についてはここをクリックして下さい。

全体 | ページ全体を表示します。
拡大 縮小 | ボタンをクリックすると表示を一定割合拡大または縮小することができます。拡大縮小は、１％～６００％の範囲で行われます。マウスホイールの前後でもそれぞれ拡大縮小できます。
節点番号 | 節点番号の表示・非表示を切り替えます。
部材番号 | 部材番号の表示・非表示を切り替えます。
部材バネ | 部材ばねの表示・非表示を切り替えます。
荷重 | 部材荷重および節点荷重の表示・非表示を切り替えます。荷重の差が大きい場合に小さな荷重が埋もれて見づらくなってしまうケースに対応して一部の部材荷重のみを表示とすることができます。
図のコピー | 構成図をクリップボードにWMFファイルとしてコピーします。 キーを押しながらボタンをクリックすると 水色 で描かれている部材を計算結果と同じ 茶色 に変更してコピーします。
スクロール | 拡大時のスクロールはスクロールバーまたは、図をマウスの左ボタンを押したままドラッグすることで行なうことができます。
再描画 | ウィンドウ内の構成図をダブルクリックすると再描画を行ないます。通常はExcelのセル位置移動するかウィンドウサイズを変更すると自動的に再描画されます。

■ 構成図ウィンドウがアクティブになるとマウスやキー操作は構成図ウィンドウに対して行なわれます。再度シートに対して操作を行ないたいときには先にシート等をクリックしてExcelをアクティブにして下さい。

■ 構成図ウィンドウの表示位置はブックごとに記録され、次回表示の時には最後に閉じたときの位置と大きさで表示されます。Excelのウィンドウを小さくするなどして構成図ウィンドウが見えなくなってしまった場合は、一度非表示にしてから再度表示するとある程度調整されます。

■ Eｘcelの［ウィンドウ］メニューの［新しいウィンドウを開く］では同一ブックが異なるウィンドウで開かれ、片方の修正はリアルタイムに他のウィンドウに反映されます。構成図ウィンドウはExcelのウィンドウに所属しますので、それぞれのウィンドウに開けますが、リアルタイムに連動することはできません。


構成図での表現

● 節点

節点は青丸で表現し、節点番号の表示が選択されていると円の左上に番号を描きます。

● 部材

節点は節点間をつなぐ水色の太線で描かれます。部材番号の表示が選択されていると部材上に緑の円の中に部材番号を描きます。

● 結合

部材データにより以下のように表現されます。

● 着目点

着目点は部材の中に小さな黄丸を描いて表現します。

● 部材バネ

部材バネは左側 I I端、右側 J端としたときに下側に薄柿色で表現します。直角方向バネでは縦線、軸方向バネでは横線が引かれます。

● 支点

支点は支点条件により以下のように描かれます。○はFix、－はFreeを示します。

水平方向 | 鉛直方向 | 回転 | マーク
○ | ○ | ○ |
○ | ○ | － |
○ | － | ○ |
－ | ○ | ○ |
○ | － | － |
－ | ○ | － |
－ | － | ○ |
バネ | － | － |
－ | バネ | － |
－ | － | バネ |

上のマークは条件設定における表現を示しています。実際の条件として正当であることを意味しません。

● 部材荷重

部材の荷重は種別により以下のような描かれます。

部材荷重の内 ［①部材直角方向集中荷重］および［②部材直角方向分布荷重］では座標系作用方向を部材座標系または構造座標系から選択できます。

構成図では荷重設定のチェックが緩やかになっており、描画されていても計算時のチェックでエラーとなる場合があります。

● 節点荷重

節点荷重は以下のように描かれます。荷重の作用方向は構造座標系に従います。


一部荷重の抽出表示

   荷重データの荷重種類の文字色を［40%灰色］または［25%灰色］にすると構成図に描画されなくなります。ただし、計算には影響しません。
   下の例のように大きな荷重を非表示にすることにより小さな荷重だけを強調して表示することができます。下の例ではデータＮｏ.4～6の荷重種類の文字色を黒のまま残して他を灰色に変更しています。

■ セルの文字色を変更するにはＥｘｃｅｌの［ツール］メニューでシートの保護を解除する必要があります。

■ セルの文字色を変更しただけでは再描画されません。変更後セル位置を移動するかウィンドウ内の図をダブルクリックすると再描画します。


節点データ

   節点のX、Y座標を入力します。データが入力されると構成図ウィンドウには節点が描画されます。

X座標 | 全体座標系における水平方向の座標を入力します。
Y座標 | 全体座標系における垂直方向の座標を入力します。


部材データ

   部材を構成する節点番号、結合条件、断面諸値、バネおよび着目点を入力します。データが入力されると構成図ウィンドウには部材が描画されます。

I 端 J 端 |  | 部材の I 端、J端側の節点番号を入力します。
I 端結合 J 端結合 |  | 部材の I 端、J端側の結合条件を入力します。 剛結は 1、ヒンジは 0 を入力します。
断面積 |  | 断面積を ㎡ の単位で入力します。
断面二次ﾓｰﾒﾝﾄ |  | 断面二次ﾓｰﾒﾝﾄを m4 の単位で入力します。
弾性係数 |  | 弾性係数を kN/㎡ の単位で入力します。
線膨張係数 |  | 線膨張係数を m/m/DEG の単位で入力します。温度荷重が無いときは入力する必要はありません。
直角方向バネ |  | 直角方向バネを kN/㎡ の単位で入力します。
軸方向バネ |  | 軸方向バネを kN/㎡ の単位で入力します。
着目点 | ① | 着目点がある場合に I 端からの距離を入力します。着目点を分割数で入力する場合は、分割数にマイナスをつけて入力します。分割数の入力は 2≦ｎ≦80
 | ②～⑧ | 着目点がある場合に I 端からの距離を入力します。着目点を分割数で入力した場合は入力できません。
部材長 |  | I 端、J端の節点番号と節点データの座標から計算した部材長を表示します。計算はExcelの関数により行なわれています。入力はできません。

着目点を入力しなくても作図用に内部で自動的に着目点を設定します。自動着目点は部材間隔0.5ｍとしたときの分割数か6分割のどちらか大きい分割数となります。


支点データ

   支点の条件を入力します。データが入力されると構成図ウィンドウには状態に応じて支点が描かれます。

   拘束状態が自由の場合は 0（ｾﾞﾛ）または空白、固定の場合は -1 、バネの場合はバネ値を入力します。

節点番号 | 支点を設ける節点番号を入力します。
水平方向 鉛直方向 | 0（自由）、-1（固定）またはバネ値を kN/m の単位で入力します。
回転 | 0（自由）、-1（固定）またはバネ値を kN･m/Radian の単位で入力します。


荷重データ

   部材上の荷重を入力します。データが入力されると構成図ウィンドウには状態に応じて荷重が描かれます。

部材№ | 荷重を受ける部材番号を入力します。
荷重種類 | 荷重の種類を選択します。荷重はしたの図に有る６種類から選択します。 荷重種類の文字色を灰色とすることで一部荷重を抽出表示することができます。
離れ L1 | I 端からの離れを入力します。集中荷重およびモーメント荷重では L1 ＞ ０として下さい。節点上に設置したい場合は節点荷重データとしてください。また、温度変化では空欄として下さい。
離れ L2 | 集中荷重およびモーメント荷重では I 端からの離れを入力します。分布荷重ではJ 端からの離れを入力します。集中荷重およびモーメント荷重では L2 ＞ ０として下さい。節点上に設置したい場合は節点荷重データとしてください。また、温度変化では空欄として下さい。
荷重 P1 | 離れ L1 位置の荷重強度を集中荷重および分布荷重では kN、モーメント荷重では kN･m の単位で入力します。また、温度変化では温度を DEG の単位で入力します。
荷重 P2 | 離れ L2 位置の荷重強度を集中荷重および分布荷重では kN、モーメント荷重では kN･m の単位で入力します。また、温度変化では空欄として下さい。
座標系 | 荷重の座標系を選択します。0（ｾﾞﾛ）または空白のとき部材座標系が採用されます。荷重種類が①部材直角方向集中荷重、②部材直角方向分布荷重の場合は構造座標系の鉛直方向（=1）または水平方向(=2)とすることができます。
荷重コメント | 荷重に対するコメントを入力します。


節点荷重データ

   節点上の荷重を入力します。データが入力されると構成図ウィンドウには状態に応じて節点荷重が描かれます。

部材№ | 荷重を受ける節点番号を入力します。
水平方向 | 水平方向の集中荷重を kN の単位で入力します。
鉛直方向 | 鉛直方向の集中荷重を kN の単位で入力します。
回転 | モーメント荷重をkN･m/Rad の単位で入力します。


計算結果シート

計算が終了すると［計算結果］シートには以下のように結果が出力されます。オプションでシートの削除が選択されていると、既に［計算結果］シートがある場合は計算に先立って削除されます。図のサイズや出力スタイルはオプションにより設定することができます。


計算結果の表

変位量、支点反力および断面力はExcelのセルを使用して以下のような表に出力されます。それぞれの値は変位に対する座標系、反力に対する座標系および応力に対する座標系に基づいて出力されます。断面力ではオプションにより選択されたポイントが出力されます。


計算結果の図

変位図、軸力図、セン断力図およびモーメント図をExcelのシェイプを使用して以下のように出力されます。図はグループ化されており、図を選択して右クリックして表示されるショートカットメニューの［グループ化］-［グループ解除］で個々のパーツに分解することができます。グループ化は階層的に行なわれていますので必要に応じて分解していくことによりシート上で自由なレイアウトをつくることができます。

図のフレーム部材上にマウスを置くと下の変位図の下側部材に示すようなツールチップが表示され部材番号とI端、J端側の節点番号を知ることができます。作図サイズや図の別シート出力などの各種設定をオプションで行なうことができます。


オプション　［全般］

デ｜タブック作成時の処理 | 扱いデータ数 | データ用ブックを新規に作成するときのデータ数を指定します。各データ数は使用上の制限に示す範囲で入力することができます。 作成されたデータ範囲には FrameDataArea の名前が付けられます。既に作成されたデータブックに対しては何ら影響しません。既に作成されたデータブックの有効データ範囲を変更するには有効データ範囲の拡張を参照して下さい。
 | シート保護 | 新規に作成されたデータ用ブックで各シート保護をするときにチェックします。Excelの［ツール］メニューの［保護］で保護するのと同じです。パスワードなしで保護され、不用意に設定を乱さないように通常は保護することをお薦めします。入力セルではロックが解除されていて保護されていても入力できます。
 | 枠線非表示 | 新規に作成されたデータ用ブックで各シートの枠線を非表示とするときにチェックします。Excelの［ツール］メニューの［オプション］-［表示］タブのウィンドウオプション欄の［枠線］のチェックを外すのと同じです。
 | 行列番号 非表示 | 新規に作成されたデータ用ブックで各シートの行列番号を非表示とするときにチェックします。Excelの［ツール］メニューの［オプション］-［表示］タブのウィンドウオプション欄の［行列番号］のチェックを外すのと同じです。
 | 解説図、入力用 コメントを出力 | 新規に作成されたデータ用ブックで［支点データ］、［荷重データ］および［節点荷重データ］シートに解説図、［部材データ］および［荷重データ］の先頭行で表示される入力用コメントを表示するときにチェックします。解説図はクリップアートとして図が挿入され、入力メッセージはExcelの［データ］メニューの［入力規則］の［入力時メッセージ］として設定されます。 解説図および入力用コメントを非表示としたときもExcelメニューの［データ］-［入力規則］-［設定］や［書式］-［条件付き書式］で設定されたデータチェックの設定は有効となります。
シート削除せずに 上書きする |  | デフォルトでは計算時に、既に［計算結果］シートがある場合そのシートは削除されますが、シートを削除せずに上書きで出力する場合にチェックします。計算結果シートの値を他のシートの数式で参照している場合、シートが削除されるとその後同じ名前のシートを作成しても #REF エラーとなってしまいます。シートの上書きとすれば再計算で参照を壊さず計算値を有効にできます。 ・上書きでは構造が変更されたり出力内容が大きく変更になると乱れる場合があります。 ・上書きに先立ってシートクリア(ｴｸｾﾙ編集ﾒﾆｭｰの［ｸﾘｱ］-[すべて]と同じ）および名前の先頭4文字が"EFP_”のシェイプの削除が行なわれます（その他のシェイプは再計算後も残ります）。
シート削除の 確認をしない |  | 既に［計算結果］シートがあり、シートの削除が選択されている場合、削除に先立って確認のメッセージが表示されますが、その確認メッセージを省略する場合にチェックします。
ツールバーの テキスト非表示 |  | デフォルトでは『ExcelでFramePro』ツールバーのボタンにはアイコンとテキストが表示されますが、テキストを表示せずツールバーを小さくしたいときにチェックします。


オプション　［結果出力］

部材断面力
計算値
● 計算点全部出力 | ： | 入力した着目点、作図用自動着目点、M-peakおよび端部の全てのポイントの断面力を計算結果の表に出力します。
● 着目点のみ出力 | ： | 入力した着目点と端部の断面力を計算結果の表に出力します。
● 端部のみ出力 | ： | 端部の断面力のみを計算結果の表に出力します。
M-peak出力

  部材断面力計算値が［計算点全部］以外の時に選択できます。チェックすると部材に分布荷重が作用したときに、せん断力 0 位置を求めM-peakとして部材断面力を出力します。
結果表の縦並び

  デフォルトでは計算結果表は横並びですが、チェックボックスをチェックすると計算結果の表を縦並びにします。

横並び | 縦並び
結果シートの
表示縮尺

   計算結果を見やすくするために計算結果シート作成時の表示縮尺を選択します。Excelの［表示］メニューの［ズーム］で指定するのと同じです。

『Excel;でFramePro』用ブックがアクティブでないときは入力できません。


オプション　［作図スタイル］

作図種別 |  | 変位図、軸力図、せん断力図およびモーメント図の中で作図したい種類にチェックします。
結果のみで作図 |  | 応力図をオプションの結果出力で選択された部材断面力計算値のみで描きたいときにチェックします。
別シートに作図 |  | 図を［計算結果］シートではなく、［計算結果図］シートに出力したいときにチェックします。
応力図への値出力 | 出力パターン | 応力図へ値を出力する場合の形式を選択します。［結果出力された断面力］を選択するとオプションの結果出力タブの［部材断面力計算値］の選択により断面力表に出力されたポイントが出力されます。
 | 小数点以下桁数 | 断面力計算結果は倍精度の値を保持していますが、応力図へ値を表示するときの小数点以下桁数を指定します。（計算結果出力表へは常に小数点以下5桁で出力します）
 | 出力位置の線 | 部材中央部の出力位置を分り易くするために、図に部材からの垂線を引くときにチェックします。

『Excel;でFramePro』用ブックがアクティブでないときは入力できません。


オプション　［作図サイズ］

作図幅 | 変位図および応力図の作図幅を指定します。作図幅は最も左にある節点と最も右側にある節点の間隔を示します。縦方向は作図幅から計算されたスケールにより決定されます。 作図幅や最大値幅の関係でExcelの図形が小さくなると描けないことがあります。適切な値に調整して下さい。
最大応力値の幅 | 応力の絶対値の最大値を描く幅を指定します。軸力、セン断およびモーメントの各最大応力はそれぞれ指定値からスケーリングされます。
最大変位量の幅 | 水平および鉛直変位の絶対値の最大値を描く幅を指定します。指定値からスケーリングされます。
図とﾀｲﾄﾙとの間隔 | 変位図および応力図の上側には図のタイトルが出力されます。そのタイトルの描画位置として、最も上にある節点とタイトルボックス下側との間隔を指定します。
次図とﾀｲﾄﾙとの間隔 | 各図は縦に並べて描かれます。各図の描画位置として、上側の図の最下点とタイトルボックス上側との間隔を指定します。
応力図値文字ｻｲｽﾞ | 応力図へ値を出力する場合の文字サイズを選択します。

『Excel;でFramePro』用ブックがアクティブでないときは入力できません。


Excelの便利な機能

Excelには非常に多くの機能があります。ここに示すのは特に珍しかったり難しかったりするものではありませんが、『ExcelでFramePro』を使用する上で有効と思われる機能で、うっかりすると見落とされがちな機能を参考までにピックアップします。

● カメラ

『ExcelでFramePro』では各データを1：1でシートに割り当てていますが、部材数が小さな場合など幾つかのデータを一ページにまとめて印刷したい場合があります。そんなときにカメラが便利です。詳しくはここをクリック。

● シナリオ

安定計算では常時と地震時を計算する場合がよくあります。その場合、荷重だけが変化しますので、荷重データにシナリオを使うことで、ひとつのブックで複数のケースを扱うことができます。詳しくはここをクリック。

● 配置/整列

『ExcelでFramePro』では応力図を縦に並べて出力しますが、横に並べたいときもあります。そんなときの位置合せに便利な機能です。詳しくはここをクリック。

● シート管理

これはExcelの機能ではありませんが、弊社提供のフリーソフト DualToolアドインを使うと、シートの保護・解除や閲覧などが簡単に行なうことができます。詳しくはここをクリック。


サポートについて

  本製品のサポートは弊社HPのメンバーサポートにて最新の修正版をご提供することで行ないます。ご購入後弊社からお知らせするサポートIDとパスワードにてアクセスすることが可能です。

  本製品に付いてのお問い合わせはHPに示されたメールにて受け付けます。ただし、お問い合わせ内容は、本製品の使用法、考え方およびご要望などに限らせていただきます。WindowsやExcelについての基本的な事項や初歩的な事柄に関するサポートに付いてはご容赦願います。

  『ExcelでFramePro』に関するサポート導入ページへは ［FRAME］メニューの［バージョン情報］ダイアログ右上の(有)デュアル [image] をクリックするアクセスできます。

『ExcelでFramePro』はまだまだ発展途上です。多くのご要望が有ると思いますが、お受けしたご要望に対応できない場合もありますので予めご了承下さい。


著作権

本製品は、日本国著作権法および国際条約により保護されています｡
本製品の全部または一部を無断で複製したり、無断で複製物を頒布すると、著作権の侵害となりますのでご注意下さい。

本製品には以下の著作物が含まれています。

ExcelでFramePro.dll | Copyright (C) 2003-2005 有限会社 デュアル
DualGL3.dll | Copyright (C) 1998-2005 有限会社 デュアル
VSDraw8.ocx | VS-VIEW 8.0J Classic Edition Copyright (C)2001,2003 ComponentOne LLC.
その他 | 著作権表示が義務付けられてはいませんが、弊社の立場で再配布を許可された著作物


使用許諾条件

重要―以下の使用条件を注意してお読みください。お客様 (個人または法人のいずれであるかを問いません) は、下記に示された使用許諾条件に同意された場合のみ、本製品のインストールまたは使用が許諾されます。承諾されない場合は未使用のソフトウェア製品を直ちにご返品ください。

１．使用許諾

これは、有限会社デュアル（以下 「デュアル」という）が本ソフトウェア使用許諾条件とともにご提供するソフトウェア製品（コンピュータプログラムとマニュアルその他の関連資料を含み、以下「本製品」といいます）をご使用になった場合は、下記の条件のすべての内容を受諾したことを意味します。お客様が、本条件に同意されない場合は、本ソフトウェアを使用せずに破棄してください。本ソフトウェアの著作権、その他知的所有権等の一切の権利は、デュアルが保有しています。

２．使用制限

(a) お客様は、本製品を単一のコンピュータにおいて非独占的に使用することができます。ネットワークサーバに本製品をインストールし、複数のコンピュータを接続して使用する場合は、接続台数分のライセンスが必要となります。

(b) お客様は、正規のユーザー登録を行った担当者の管理下においてのみ、本製品を使用できます。

３．禁止事項

(a) お客様は、デュアルの書面による事前の同意を得なければ、本製品を第三者に譲渡、販売、転貸することはできません。

(b) 本製品のマニュアルその他に明示されている場合を除き、本ソフトウェアまたはマニュアルその他関連資料の全部または一部を、印刷または複製することはできません。

(c) いかなる場合においても、本ソフトウェアの全部、または一部を、翻案または別のソフトウェアと組み合わせたりしてはならないものとします。

(d) お客様は、本ソフトウェアをリバースエンジニアリング、逆コンパイル、または逆アセンブルしてはなりません。

４．保証の範囲および免責事項

(a) 本製品に目的を遂げることができない重大な欠陥（磁気の消滅、破壊等）があった場合や、重大な誤りを発見したときは、本製品購入から１年以内に限り、無償で対処します。

(b) デュアルは前項に定める場合を除き、本製品に関していかなる保証も行いません。デュアルはいかなる場合にも、お客様が本製品を使用しまたは運用した結果、直接または間接的に生じる損害に関して一切責任を負わないものとします。

(c) デュアルは本製品の仕様を予告なしに変更することがあります。

５．契約期間

(a) 本契約はお客様が製品を受領した日から発効します。

(b) お客様が、本契約の条項のいずれかに違反した場合、本契約は自動的に終了します。この場合、製品の購入代金は返還いたしません。


Excelの便利な機能　［カメラ］

カメラを使って印刷用ページを作成する方法を示します。機能としては、ある範囲をカメラで写し、それを他の位置に図として貼り付けることとなります。データシートを変更するとカメラで写された図もリアルタイムに変更されますので、デジタルカメラのモニターのようなものと考えた方が分かり易いようです。
  残念なのは、写せる範囲に限界があり部材データなどは全体を一度には写せません。また、計算中もセルに書き込む度に表示の更新を行なっているのか計算時間がかなり長くなります。計算のトライアルを行なう場合には、計算が終了してから使用することをお薦めします。

● カメラのアイコンを表示する

Excelのメニューやツールバーに [image] ［カメラ］が表示されていない場合は以下の手順で追加することができます

① ［ツール］ メニューの ［ユーザー設定］ をクリックします。

② ［ユーザー設定］ ダイアログ ボックスで ［コマンド］ タブをクリックし、［分類］ ボックスの一覧の ［ツール］ をクリックします。

③ ［コマンド］ ボックスの一覧の ［カメラ］ をクリックし、ボタンを押したまま適当なツールバーにドラッグし、マウスのボタンを離します。

● 印刷用ページを作成する

① ［挿入］ メニューの ［ワークシート］ をクリックし印刷用の新しいシートを作成します。

② 対象となるデータ範囲を選択して [image] ボタンをクリックします。

③ 印刷用ページをアクティブにして貼り付けたい位置でマウスの左ボタンをクリックします。設定によっては図の外側に線が引かれてしまいます。その場合は、図が選択された状態で［書式］メニューの［図］をクリック、［色と線］タブの線で［線なし］として下さい。

④ 他に写したい個所があれば②、③を繰り返します。

⑤ 全て終了すると以下のように使用しているデータを一ページにまとめることができます。

■ カメラにはExcelの枠線も写ってしまいます。被写体となるシートの枠線は非表示とする事をお薦めします。枠線を非表示にするには［ツール]メニューの［オプション］の［表示］タブの［ウィンドウオプション］の［枠線］のチェックを外します。

■ 計算結果シートは、オプションの選択により計算に先立って削除されるため、完全に計算が終了していない時点ではカメラの被写体となることはできません。選択範囲がエラーとなり、前回の状態が図として残ってしまいます。


Excelの便利な機能　［シナリオ］

一般的なフレームでは基本荷重を入力し、それらの組合せで多様なケースを計算しますが、『ExcelでFramePro』では１ケース1ブックとしています。構造系は同じなのに荷重数分のExcelブックができてしまい煩雑になってしまう可能性があります。そんなときに有効なのがこのシナリオです。荷重に限らず節点データ、部材データや支点データにも応用できます。

ただ１点残念なことは、一度に登録できるセル数が32個なので大きなデータの時には幾つかに分けて登録しなければならないことです。

● 常時、地震時の荷重をシナリオに登録の例

   地震時には常時荷重に加えて自重に対する水平荷重を作用させます。

① ［ツール］ メニューの ［シナリオ］ をクリックします。

② ［シナリオの登録と管理］ ダイアログ ボックスで ［追加］ ボタンをクリックします。表示される［シナリオの編集］ダイアログで［シナリオ名］を入力します。

③ ［変化させるセル］に地震時に増える部分を空白として登録するために空白部分を選択し［OK］ボタンをクリックします。続いて［シナリオの値］ダイアログが表示されますので［OK］ボタンをクリック、［シナリオの登録と管理］ダイアログに戻りますので［閉じる］ボタンをクリックしてダイアログを閉じます。

④ 地震時の荷重を入力します。関数を使用して入力することもできますが、シナリオ登録時には値に変換されます。

⑤ 常時と同様に［ツール］ メニューの ［シナリオ］ で地震時の荷重をシナリオとして登録します。

⑥ シナリオが登録されると以降は［シナリオの登録と管理］ダイアログでシナリオを選択して［表示］ボタンをクリックすると登録した値が表示されます。


Excelの便利な機能　［シート管理］

『ExcelでFramePro』では複数のシートを使用しますのでシートの確認などが煩わしくなりがちです。シートを管理するには弊社ホームページよりフリーソフト(無料）の DualTool をダウンロードしてご使用いただけば以下のようなダイアログから簡単に閲覧、移動および保護解除などが行なえます。


Excelの便利な機能　［配置/整列］

『ExcelでFramePro』で出力される変位図や応力図は縦一列に並べられていますが、形状によっては横に並べたり縦横２列に並べたりするケースがあると思います。マウスでドラッグして揃えることはできますが、この機能を使うと簡単に位置を揃えることができます。

● 図を横一列に並べる時の例

① 図をマウスでドラッグして適当に横に並べ、整列したい図形を全て選択状態にします。

② エクセルの左下にある［図形の調整］-[配置/整列］-［上揃え］をクリックします。

③ 続けて［図形の調整］-[配置/整列］-［左右に整列］で間隔を揃えます。

配置/整列の機能は［ツール］メニューの［ユーザー設定］で開かれるダイアログの［コマンド]タブの［図形描画］から各ボタンをツールバーに取り出すこともできます。取り出し方はExcelの便利な機能［カメラ］を参照して下さい。


プロテクションキーの設定

プロテクションキーを有効にするには、デバイスドライバをインストールする必要があります。デバイスドライバはインストール時に自動的に組込まれますが、他のアプリケーションのアンインストールなどで削除されてしまった場合、インストールフォルダ（デフォルトでは c:\Program Files\Dual Products\DualSys）にある HaspInst.exe を実行して再インストールして下さい。

ここをクリックすればプロテクションキーユーティリティーが起動

処理を行うには、＜デバイスドライバの組込＞または＜デバイスドライバの削除＞どちらかのオプションボタンをクリックして処理を選択後、［実行］ボタンをクリックします。

■デバイスドライバの組込

インストール後にデバイスドライバを削除してしまった場合に、デバイスドライバを再インストールします。通常はデバイスドライバインストール後にコンピュータの再起動は必要ありませんが、他のアプリケーションで既に旧バージョンのデバイスドライバがインストールされている状態ではうまく動作しない場合があります。この時はコンピュータを再起動して下さい。

■デバイスドライバの削除

何らかの理由でデバイスドライバを削除する必要がある場合に選択します。ただし、デバイスドライバを削除すると『ExcelでFramePro』は実行できなくなります。

   アンインストール時には自動的にこのプロテクションキーユーティリティーが起動されます（削除のみ可能）。ウィンドウに書かれているように他のアプリケーションでこれらのデバイスドライバを使用している場合には、削除するとそのアプリケーションの実行に支障が出ます。削除したくない場合は［キャンセル］ボタンをクリックして中止して下さい。また良く分からない場合は削除を中止して下さい。（一般的には他のアプリケーションでプロテクションキーをセットする必要が無ければデバイスドライバは必要ありません。）